Download Padre

Padre for Windows (Active Perl)

Active Perl

Once you have installed Active Perl you need to configure an additional PPM repositor and then you can install Padre using the ppm packaging system. Let's see how to do it in the Command Shell:

  Start/Run/cmd ENTER
  ppm rep add wxperl  
  ppm install Alien-wxWidgets
  ppm install Wx
  ppm install Padre

You might have to install Alien-wxWidgets-gcc. If this conflicts with Alien-wxWidgets - you can try use --force:

  ppm install  Alien-wxWidgets-gcc  --force

Once that's done you can start Padre by typing

  perl c:\perl\site\bin\padre


  wperl c:\perl\site\bin\padre

Replace "c:\perl" with the path, where Active Perl is installed.

Older Active Perl details

The manual installation is still a bit rough but we are working on improving it.

1) (A) Most of the modules - can be taken from the main ActiveState Package Repository.

(B) For Active Perl there are prebuilt PPM versions of Alien::wxWidgets and Wx (aka. wxPerl) and can be installed from

So add the wxperl repository to the PPM: (for detailed instructions see ) (and even more info here )

Adding the repository to your PPM repository list: In PPM4 (ActivePerl 820+) this is most easily done via the GUI menu option: Edit -> Preferences.

If you use PPM3 - or used to command line (==DOS , still usable for PPM4) - you can do:

  ppm rep add wxperl 

2) Install all the packages (except of course perl) listed as "requires" on - by using ppm. Don't worry about the order of installation and report us any problem you encounter.

You can do in by searching the "requires" packages listed in the above link - either by using the PPM4 GUI, or searching PPM command line (==DOS):

  ppm search App::Ack

The result may look like this:

  C:\Documents and Settings\orenm>ppm search App::Ack
  Downloading ActiveState Package Repository packlist...not modified
  1: ack
   A grep-like program specifically for large source trees
   Version: 1.86
   Released: 2008-07-09
   Author: Andy Lester <>
   Provide: App::Ack version 1.86
   Require: File::Basename
   Require: File::Next version 0.4 or better
   Require: Getopt::Long
   Require: Term::ANSIColor
   Require: Test::Harness version 2.5 or better
   Require: Test::More
   Repo: ActiveState Package Repository

C:\Documents and Settings\orenm>

So now you shall do:

  ppm install ack

3) then open the cpan client and install Padre:

  c:> perl -MCPAN -eshell
  cpan> install Padre

Oren Maurer reported that you might need to force it:

  cpan> force install Padre

at some point you might encounter an error like this:

 Running install for module 'Padre'
 Running make for S/SZ/SZABGAB/Padre-0.06.tar.gz
 CPAN: Digest::SHA loaded ok (v5.45)
 Fetching with LWP:
 Alert: While trying to 'parse' YAML file
 with 'YAML::XS' the following error was encountered:
  Usage: YAML::XS::LibYAML::Load(yaml_str) at
  line 70.

The reported solution was this:

  [reach the cpan shell:]
  cpan> o conf yaml_module 
  cpan> o conf commit
  commit: wrote 'C:\Perl\lib/CPAN/'
  cpan> q

(See: and )

Other things that to do and can help:

  1. upgrading last version of Encode - using ppm

Note: For upgrading all PPM packages, do this (Windows command line, a.k.a Dos)

    ppm upgrade --install 
  1. upgrade of Wx - also by using ppm
  2. installing Alien-wxWidgets (the same way... ppm),
  3. And now - do (again with ppm):
    ppm install  --force Alien-wxWidgets-dev


For more info about "ppm - Perl Package Manager, version 4" - see the ActivePerl 5.10 Documentation

Still Not Working?

Following the instructions on this page did not lead to a successful installation?

Contact us.

We will do our best to help you. By letting us know that something does not work you will help us, too. When we know about it, we can improve this documentation and Padre itself.