Opened 4 years ago

Closed 4 years ago

#1007 closed defect (fixed)

warn output overwrites file name and other warns in Linux

Reported by: kthakore Owned by: garu
Priority: major Milestone:
Component: editor Version: 0.70
Keywords: Cc:

Description (last modified by garu)

To reproduce:

1) Open Padre
2) Write the following code:

use strict;
use warnings;

foreach(0...5)
{
 
 warn 'asdfdsfds';	
 warn '123123213123';
	
}

3) Save as foo.pl and Execute with F5

asdfdsfds at /home/kthakore/Documents/foo.pl line 7.
123123213123 at /home/kthakore/Documents/foo.pl line 8.
123123213123 at /home/kthakore/Documents/foo.pl line 7.
123123213123 at /home/kthakore/Documents/foo.pl line 8.
123123213123 at /home/kthakore/Documents/foo.pl line 7.
123123213123 at /home/kthakore/Documents/foo.pl line 8.
...

This is incorrect. It should alternate.

4) Type a space in the editor and it will change the file name

See attached screen shot

Attachments (1)

Screenshot.png (102.4 KB) - added by kthakore 4 years ago.
The foo.pl has been changed in filename.

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by kthakore

The foo.pl has been changed in filename.

comment:1 Changed 4 years ago by garu

  • Description modified (diff)

I am able to reproduce this in r12464. If you set Padre to use an external window (instead of the output panel), the problem does not appear.

comment:2 Changed 4 years ago by kthakore

The problem is here:

lib/Padre/Wx/StatusBar.pm 191

File::Basename::basename($filename)

That is where the weird overflow happens in @_ and $_ I think. But if you print that out while running this bug it is concat there.

comment:3 Changed 4 years ago by garu

Output panel buffering issues fixed in revision 12465. Thanks for the bug report!

I'll leave this ticket open until the basename bug is fixed as well.

comment:4 Changed 4 years ago by kthakore

  • Owner set to garu
  • Status changed from new to assigned

comment:5 Changed 4 years ago by kthakore

  • Resolution set to fixed
  • Status changed from assigned to closed

Can no longer reproduce the bug.

Note: See TracTickets for help on using tickets.