Opened 4 years ago

Closed 2 years ago

#1031 closed defect (not relevant)

Padre crashes when clicking "Install CPAN modules"

Reported by: migmir Owned by:
Priority: major Milestone:
Component: CPAN Module Installer Version: 0.72
Keywords: menu Tools CPAN modules Cc:

Description

Padre crashes when trying to use :

Tools => Module Tools => Install CPAN modules"

I first observed this in version 0.63 shipped with the padre+perl .msi installed downloaded from the website.

I tried upgrading Padre ( through command line cpan Padre ) to v0.72, but the crash still occurs.

However as someone pointed out on the #padre channel, the crash does not occur when running padre from the padre.bat script


System :
Windows 7 64 bit
perl info :
This is perl, v5.10.1 (*) built for MSWin32-x86-multi-thread
wx info :
Wx Version=(0.9702) wxWidgets 2.8.10 unicode=(1)

Change History (6)

comment:1 Changed 4 years ago by zenogantner

  • Component changed from editor to advanced perl tools

I also have a crash on Ubuntu 10.04 (version 0.73):

This is the message I get:

Can't write to '/home/mrg/.local/share/.cpan/sources/authors/01mailrc.txt.gz.tmp6395-6395': Permission denied at /usr/share/perl5/LWP/Protocol.pm line 105. at /usr/share/perl5/LWP/UserAgent.pm line 844.

comment:2 Changed 4 years ago by zenogantner

I cannot reproduce my report from 3 weeks ago (now on 0.75), but this 'works':

  1. use sudo cpan outside of Padre
  2. Try to install a new module inside of Padre.

Result: Padre crashes with

L: Test::Perl::Dist
mkdir /home/mrg/.local/share/.cpan/sources/authors/id/C/CS: Permission denied at /usr/share/perl/5.10/CPAN/FTP.pm line 501
Perl exited with active threads:

comment:3 Changed 4 years ago by migmir

Upgraded Padre to 0.74 through "cpan Padre", problem persists.

comment:4 Changed 4 years ago by zenogantner

#501 looks similar.

comment:5 Changed 4 years ago by szabgab

  • Component changed from advanced perl tools to CPAN Module Installer

comment:6 Changed 2 years ago by bowtie

  • Resolution set to not relevant
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.