Ticket #1035 (closed defect: not a bug)

Opened 3 years ago

Last modified 2 years ago

Padre hangs while debugged script hangs

Reported by: dandv Owned by: szabgab
Priority: critical Milestone:
Component: Debugger for Perl 5 Version: 0.72
Keywords: Cc:

Description

If you debug a script that does a WWW::Mechanize->get(...something slow that will eventually time out...), Padre will hang while the "get" tries to fetch the URI.

use strict;
use WWW::Mechanize;

my $mech = WWW::Mechanize->new();

$mech->get("http://1.2.3.4");

Change History

comment:1 Changed 2 years ago by bowtie

  • Status changed from new to closed
  • Resolution set to not a bug
  • Component changed from Debug::Client to Debugger for Perl 5

A Gateway Time-Out is not an error of either Debug::Client of Padre Debugger.
tested under Debug2 on trunk 0.93
All you have to do is wait for time out.

remember Garbage In => Garbage Out

Note: See TracTickets for help on using tickets.