Opened 4 years ago

Closed 2 years ago

#1094 closed defect (cannot reproduce)

Find in file crashes Padre trunk

Reported by: Nanoprobe Owned by:
Priority: major Milestone:
Component: Find in Files Version: trunk
Keywords: crash Cc:

Description

Sometimes when editing a file, Ctrl+F crashes Padre with the following error in the terminal.

Can't locate object method "run" via package "Padre::Wx::Dialog::Find" at /home/Nanoprobe/padre/Padre/lib/Padre/Wx/ActionLibrary.pm line 1141.
Perl exited with active threads:

1 running and unjoined
0 finished and unjoined
0 running and detached

Diagnostic info:
Padre version: Trunk, revision 13616

perl -MWx -e'printf(qq(Wx Version=($Wx::VERSION) %s unicode=(%s)\n), Wx::wxVERSION_STRING(), Wx::wxUNICODE())'

Wx Version=(0.98) wxWidgets 2.8.11 unicode=(1)

perl -v

This is perl, v5.10.1 (*) built for i686-linux-gnu-thread-multi

(with 40 registered patches, see perl -V for more detail)

Change History (5)

comment:1 Changed 4 years ago by szabgab

"Sometimes" is a bit hard to reproduce. Could you please try to find a way to reproduce it?

comment:2 Changed 4 years ago by Nanoprobe

It happens almost every time I search, but there seems to be no exact way I can replicate it 100%. What do you advise?

comment:3 Changed 3 years ago by zenogantner

  • Keywords crash added

Do you still see this behaviour?

Does it happen when you select the search from the menu?
Does it happen with F3?

Could the bug be related to #1100 (which was fixed)?

comment:4 Changed 3 years ago by szabgab

  • Component changed from editor to Find in Files

comment:5 Changed 2 years ago by azawawi

  • Resolution set to cannot reproduce
  • Status changed from new to closed

Outdated since "Find in files" works perfectly now.

Note: See TracTickets for help on using tickets.