Ticket #1117 (closed defect: not a bug)

Opened 3 years ago

Last modified 3 years ago

Filter through Perl: strange behavior

Reported by: zenogantner Owned by:
Priority: major Milestone:
Component: editor Version: trunk
Keywords: Cc:

Description

I get the behavior ("1") as shown in the screenshot. Why is that so?

What is the expected behavior of the Perl script?
I guess it receives data via STDIN, and emits data via STDOUT.

Following this logic, "1" should not be the result.

Also, the way the Perl filter worked should be clear from the UI (i.e., it should be explained by the dialog elements and/or tooltips)

Attachments

padre-perlfilter.png (38.6 KB) - added by zenogantner 3 years ago.

Change History

comment:1 Changed 3 years ago by zenogantner

PS: STDOUT of the Perl filter seems to be redirected to Padre's STDOUT.

Changed 3 years ago by zenogantner

comment:2 Changed 3 years ago by Sewi

  • Status changed from new to closed
  • Resolution set to not a bug

The filter script should expect data in $_ and return it in $_ - which is ok for version 1 but should be upgraded to more options (like STDIN/STDOUT).

Note: See TracTickets for help on using tickets.