Opened 3 years ago

Last modified 3 years ago

#1133 new defect

./dev can not be run on the branch

Reported by: jagd Owned by:
Priority: major Milestone:
Component: development Version: 0.82pre
Keywords: branch Cc:

Description

$ svn co http://svn.perlide.org/padre/branches/release-0.82
$ perl Makefile.PL && make
no errors during make are reported

however, ./dev can not be launched, since:

Could not find icon 'status/padre-fallback-icon'! at padre/lib/Padre/Wx/Icon.pm line 125
        Padre::Wx::Icon::find('status/padre-fallback-icon') called at padre/lib/Padre/Wx/Icon.pm line 115
        Padre::Wx::Icon::find('actions/document-new') called at padre/lib/Padre/Wx/ToolBar.pm line 132
        Padre::Wx::ToolBar::add_tool_item('Padre::Wx::ToolBar=HASH(0x96b41a0)', 'action', 'file.new') called at padre/lib/Padre/Wx/ToolBar.pm line 66
        Padre::Wx::ToolBar::new('Padre::Wx::ToolBar', 'Padre::Wx::Main=HASH(0x94dfed0)') called at padre/lib/Padre/Wx/Main.pm line 213
        Padre::Wx::Main::new('Padre::Wx::Main', 'Padre=HASH(0x8331c48)') called at padre/lib/Padre/Wx/App.pm line 73
        Padre::Wx::App::create('Padre::Wx::App', 'Padre=HASH(0x8331c48)') called at padre/lib/Padre.pm line 157
        Padre::new('Padre', 'files', 'ARRAY(0x82eed90)', 'session', undef, 'actionqueue', undef, 'startup_locale', undef, ...) called at padre/script/padre line 152
Perl exited with active threads:
        1 running and unjoined
        0 finished and unjoined
        0 running and detached

Wx Version=(::VERSION) wxWidgets 2.8.11 unicode=(1)
on Fedora 14

Change History (5)

comment:1 Changed 3 years ago by zenogantner

  • Version changed from trunk to 0.82pre

comment:2 Changed 3 years ago by Sewi

We have 0.84 now - is this problem still alive?

comment:3 Changed 3 years ago by szabgab

  • Component changed from editor to development

this happened to me on the 0.84 release branch

comment:4 Changed 3 years ago by dolmen

Same problem on the 0.90 branch.
However launching the padre script manually is fine: perl -Iblib/lib blib/script/padre

Looks like it is a problem only in the 'dev' script which makes some assumptions.

comment:5 Changed 3 years ago by zenogantner

I cannot reproduce this on Ubuntu 10.04 w/ Perl 5.10.1, Wx 0.99, wxWidgets 2.8.10, Alien::wxWidgets 0.51.

Note: See TracTickets for help on using tickets.