Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#1153 closed defect (fixed)

title bar $version

Reported by: bowtie Owned by:
Priority: minor Milestone:
Component: Title and Status Bar Personalization Version: 0.82
Keywords: Cc:

Description

$ perl -v

This is perl, v5.10.1 (*) built for i686-linux-gnu-thread-multi
(with 40 registered patches, see perl -V for more detail)

Copyright 1987-2009, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using "man perl" or "perldoc perl". If you have access to the
Internet, point your browser at http://www.perl.org/, the Perl Home Page.

perl -MWx -e'printf(qq(Wx Version=($Wx::VERSION) %s unicode=(%s)\n), Wx::wxVERSION_STRING(), Wx::wxUNICODE())'
Wx Version=(0.98) wxWidgets 2.8.11 unicode=(1)

uname -a
Linux nx9005 2.6.35-27-generic #48-Ubuntu SMP Tue Feb 22 20:25:29 UTC 2011 i686 GNU/Linux

installed from CPAN on 03/03/2011

Padre 0.82 title bar

if Tools->Preferences->Apperance->Window title: contains Padre-%v_[%p-%f]

Use of uninitialized value within %variable in substitution iterator at /usr/local/share/perl/5.10.1/Padre/Wx/Main.pm line 1388.
Scalars leaked: 1
Scalars leaked: 1
Scalars leaked: 2
Scalars leaked: 2
Scalars leaked: 1
Segmentation fault

crashes out while editing any file.

quick fix remove contents from

Tools->Preferences->Apperance->Window title:

regards
kevin

Change History (11)

comment:1 Changed 3 years ago by bowtie

  • Priority changed from major to minor

Opps, sorry wrong priority

regards
kevin

comment:2 Changed 3 years ago by zenogantner

  • Summary changed from titie bar $version to title bar $version

fix typo in summary.

comment:3 Changed 3 years ago by zenogantner

I cannot reproduce this bug on Ubuntu 10.04 LTS.

This is perl, v5.10.1 (*) built for i486-linux-gnu-thread-multi
Linux take 2.6.32-29-generic #58-Ubuntu SMP Fri Feb 11 19:00:09 UTC 2011 i686 GNU/Linux

comment:4 Changed 3 years ago by szabgab

I could reproduce the warning but not the crash. Ubuntu 10.10 r13896

comment:5 Changed 3 years ago by zenogantner

The warning is not related to the crash, I also see it, and it has been reported in #1138.

comment:6 Changed 3 years ago by bowtie

as requested

System Info
Perl 5.10.1
Wx 0.98
wxWidgets 2.8.11
Wx::Perl::ProcessStream? 0.30
PPI 1.215
Config: ~/.local/share/.padre
Uptime: 0:00:25
RAM: 155.1MB
Threads: 3

comment:7 Changed 3 years ago by zenogantner

  • Resolution set to fixed
  • Status changed from new to closed

I fixed the warnings in r13900.

If you want to check whether the crash is gone as well, please check the trunk version of Padre from the SVN repository.

Please re-open if you still encounter this problem.

comment:8 Changed 3 years ago by szabgab

The fix has involved 3 changes:
r13899, r13900 and tidying: r13904

comment:9 Changed 3 years ago by szabgab

  • Resolution fixed deleted
  • Status changed from closed to reopened

using r13904 I just got the warning again:

Use of uninitialized value within %variable in substitution iterator at /home/gabor/work/padre/Padre/lib/Padre/Wx/Main.pm line 1394

my Title is set to be

%b - %f - %p - %d - %F %v %x %%

for testing purposes

comment:10 Changed 3 years ago by szabgab

  • Resolution set to fixed
  • Status changed from reopened to closed

further fix in r13905

comment:11 Changed 3 years ago by szabgab

  • Component changed from editor to Title and Status Bar Personalization
Note: See TracTickets for help on using tickets.