Opened 4 years ago

Closed 3 years ago

#1155 closed defect (fixed)

Outline and Functions don't work with unsaved files

Reported by: azornik Owned by:
Priority: minor Milestone:
Component: Outline Version: 0.82
Keywords: outline, functionlist, right Cc:

Description

the outline and function features are not working with unsaved files

  • open padre
  • open write script, example: {sub fetch_main_dist {

my $self = shift;
my $term = shift;
my $dist = CPANDB->distribution($term);

sub _build_gui {

my $self = shift;
my $glade = $self->glade_path;
return Gtk2::GladeXML->new($glade);

}

  • than enable outline and functions, "View->Show Outline" "View->Show Functions".

when I enable those functions I want to see the functions and methods but its only working with saved files.

Change History (4)

comment:1 Changed 4 years ago by azornik

  • Summary changed from Outline and Functions features's bug to Outline and Functions don't work with unsaved files

comment:2 Changed 4 years ago by zenogantner

  • Component changed from editor to advanced perl tools
  • Keywords outline functionlist right added

Observation: on trunk r13983, the function list does not display anything if it is open before I enter the code.

If I activate the function list after entering the code, it immediatly shows the functions.

For the outline view, I cannot reproduce the described behavior at all. It takes about three seconds for the outline to show up, but then it is there.

azornik, could you check whether the behavior is different if the function list/outline is activated before/after the text input, and if the problem with the outline could be the delay?

comment:3 Changed 4 years ago by szabgab

  • Component changed from advanced perl tools to Outline

comment:4 Changed 3 years ago by adamk

  • Resolution set to fixed
  • Status changed from new to closed

I believe the task manager changes should mean this is fixed now, closing.

Note: See TracTickets for help on using tickets.