Ticket #1184 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Perl help browser suppresses linebreaks

Reported by: Sewi Owned by:
Priority: major Milestone:
Component: editor Version: 0.85
Keywords: Cc:

Description

  • Type the name of any installed Module (tried SVN::Class and some eBay API calls)
  • place the cursor into the module name
  • press F2

The POD of the module is shown, but it's missing any linebreaks (\n)

Ubuntu 10, Padre trunk r14125

Attachments

padre1.png (181.7 KB) - added by zenogantner 3 years ago.
screenshot of the problem by user gyles19 on IRC

Change History

comment:1 Changed 3 years ago by zenogantner

Cannot reproduce here, but another user reported it in IRC, too.

Ubuntu 10.04 with Padre from trunk r15952.

System Info:

Perl 5.10.1 
Wx 0.99 
wxWidgets 2.8.10
Alien::wxWidgets 0.51

Changed 3 years ago by zenogantner

screenshot of the problem by user gyles19 on IRC

comment:2 Changed 3 years ago by gyles19

I found bug http://padre.perlide.org/trac/ticket/941 (closed as invalid) which indicates the problem is the version of wx installed on ubuntu. The current build packages available from ubuntu repos is 0.96.

It appears that the wx version tests in padre are specific to windows, and so aren't triggering any warnings when non-windows platforms launch padre.

I had to manually download and build a bunch of stuff, starting with wxperl, from CPAN just to get padre running on Ubuntu 10.04. The ubuntu padre package is badly broken. But nothing pointed me to go rebuild a newer version of libwx-perl (as it's known in debian packaging.)

After a great deal of searching I finally found the current version on CPAN: http://search.cpan.org/~mdootson/Wx-0.9901/

I will build this and see if it solves the issue.

comment:3 Changed 3 years ago by gyles19

Yes. Installing Wx-0.9901 fixed the help text display issue.

Has anyone created a Bundle::Padre? I searched CPAN but didn't find one.

comment:4 Changed 3 years ago by azawawi

So basically it is Debian Padre packaging issue, right?

comment:5 Changed 3 years ago by gyles19

No. From what I read in the older bug report, Padre is not version checking Wx anywhere but on Windows. It needs to version check Wx on all platforms.

The Debian packaging being broken revealed the Padre issue.

comment:6 Changed 3 years ago by azawawi

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in r16485

Thanks for your patience
Ahmad M. Zawawi (azawawi)

comment:7 Changed 3 years ago by azawawi

  • Summary changed from Perl help browser supresses linebreaks to Perl help browser suppresses linebreaks
Note: See TracTickets for help on using tickets.