Opened 3 years ago

Closed 3 years ago

#1194 closed defect (not relevant)

PPI Experimental & Skeleton Build

Reported by: bowtie Owned by:
Priority: minor Milestone:
Component: Syntax Highlighting Version: 0.85
Keywords: Cc:

Description

In the process of generating the wiki page, I note the following.

enc:
Good.pm ; is highlighted by PPIx
Bad.pm ; is highlighted by Scintilla

why?

have I done something wrong, if so what?

Attachments (2)

Good.pm (1.7 KB) - added by bowtie 3 years ago.
Bad.pm (4.8 KB) - added by bowtie 3 years ago.

Download all attachments as: .zip

Change History (9)

Changed 3 years ago by bowtie

Changed 3 years ago by bowtie

comment:1 Changed 3 years ago by szabgab

  • Component changed from editor to Syntax Highlighting
  • Resolution set to not a bug
  • Status changed from new to closed

Even if you turn PPI Syntax highlighting on, because it is very slow, there is a size limit. Files above that limit will be highlighted using Scintilla.

comment:2 Changed 3 years ago by bowtie

I think you missed the point, both files were skeleton builds, hence size of 2k and 5k, unless you are saying the file size limit is between thkes place between 2-5k.

Something is causing this, and I doubt very much in this case its file size..

comment:3 Changed 3 years ago by bowtie

  • Resolution not a bug deleted
  • Status changed from closed to reopened

comment:4 Changed 3 years ago by szabgab

In Padre::Document::Perl the limit is hard coded for 2 lexers at 4000 bytes.
One of the lexers uses the perl_ppi_lexer_limit configuration variable which,
in Padre::Config is set to a default of 4000 bytes.

comment:5 Changed 3 years ago by bowtie

Cool

changed to 8k (8192) in all three locations as suggested,

works a dream.

what is the expected, overhead?

I would like to set it @ 32768 32k, comments please

comment:6 Changed 3 years ago by bowtie

some more back ground

file Good.pm was generated using Padre Templates

file Bad.pm was generated using module::starter::PBP templates

Should Padre not be able to display any skeleton in glorious color!

would it not make more sense if 8192 was now the default.

comment:7 Changed 3 years ago by bowtie

  • Resolution set to not relevant
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.