Ticket #1215 (closed defect: wontfix)

Opened 3 years ago

Last modified 2 years ago

Cannot change the syntax highlighter of Perl 6

Reported by: szabgab Owned by:
Priority: major Milestone:
Component: Syntax Highlighting Version: 0.85
Keywords: perl6 Cc: adamk

Description

Since the move to Preferences 2.0 we cannot set the syntax highlighter of anything except Perl 5.
Scintilla was never used for Perl 6 syntax highlighting as it does not support it but we had two others.

Change History

comment:1 Changed 3 years ago by azawawi

My plan is to replace STD.pm6 highlighter that is provided by Padre::Plugin::Perl6 by a faster Perl 6 lexer. I started with it but it is currently very simple.

comment:2 Changed 2 years ago by azawawi

  • Status changed from new to closed
  • Resolution set to wontfix

Changed my plan. I am focusing on improve Perl 5 support.

Version 0, edited 2 years ago by azawawi (next)
Note: See TracTickets for help on using tickets.