Ticket #1244 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

The menu "recent files" is not updated on history updates, only with 1 file delay

Reported by: bowtie Owned by: Sewi
Priority: trivial Milestone:
Component: editor Version: 0.86
Keywords: Cc:

Description

The menu "recent files" is not updated on history updates, only with 1 file delay.

Change History

comment:1 Changed 3 years ago by bowtie

Having looked at Padre::Task::RecentFiles,

  • it is clear that the last 100 files are selected from config-db history and compared against the Padre current documents.
  • to produce a list of 9 items, which is referred to as File->Recent Files

alternatively you could have just done the following

$self->{history} = Padre::DB::History->recent( 'files', $self->{want} );

which would be the same as other software, where 5 is norm not 9.

Hence Sewi, I think it works as intended.

But not as one would expect, I think.

comment:2 Changed 3 years ago by bowtie

  • Component changed from not classified yet to editor

comment:3 Changed 3 years ago by Sewi

Padre::Task::RecentFiles? is launched when a file is opened and skips files currently open.

It is not launched if a file is closed, so the list is not updated - and the last recent opened file is missing.

comment:4 Changed 3 years ago by Sewi

  • Status changed from new to closed
  • Resolution set to fixed

fixed in r15199

Note: See TracTickets for help on using tickets.