Ticket #1255 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

The directory browser got an undef object and may stop working now. Please save your work and restart Padre

Reported by: bowtie Owned by: szabgab
Priority: critical Milestone:
Component: editor Version: 0.87
Keywords: Padre::Wx::Directory Cc:

Description

The directory browser got an undef object and may stop working now. Please save your work and restart Padre
0.87 error
0.86 no error

to generate error, use trunk perl dev -a --die

open an existing session,

then open a isolated perlfile.pl in some other dir which dose not contain any project info or padre.ymal.

which I do to test in.

and voila, an error dialog!!

error from:
package Padre::Wx::Directory;
line 516;

$self->main->error(
    Wx::gettext(
        'The directory browser got an undef object and may stop working now. Please save your work and restart Padre.'
    )
);

Change History

comment:1 Changed 3 years ago by bowtie

Opps, trunk revision 14962

comment:2 Changed 3 years ago by Sewi

  • Status changed from new to closed
  • Resolution set to duplicate

Seems to be duplicate of #1096

Note: See TracTickets for help on using tickets.