Ticket #1268 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

Padre sometimes crashes on right click in editor window

Reported by: Sewi Owned by:
Priority: critical Milestone:
Component: editor Version: 0.87
Keywords: Cc:

Description

DIE: Can't locate object method "feature_folding" via package "Padre::Config" at /home/sewi/padre/Padre/lib/Padre/Wx/Menu/RightClick.pm line 113.


at /home/sewi/padre/Padre/lib/Padre/Wx/Menu/RightClick.pm line 113

Padre::Wx::Menu::RightClick::new('Padre::Wx::Menu::RightClick?', 'Padre::Wx::Main=HASH(0x99751f0)', 'Padre::Wx::Editor=HASH(0xc8cff08)', 'Wx::MouseEvent?=SCALAR(0x921b528)') called at /home/sewi/padre/Padre/lib/Padre/Wx/Editor.pm line 1244
Padre::Wx::Editor::on_right_down('Padre::Wx::Editor=HASH(0xc8cff08)', 'Wx::MouseEvent?=SCALAR(0x921b528)') called at /home/sewi/padre/Padre/lib/Padre.pm line 249
eval {...} called at /home/sewi/padre/Padre/lib/Padre.pm line 249
Padre::run('Padre=HASH(0x9189ee8)') called at /home/sewi/padre/Padre/script/padre line 181

DIE: Can't locate object method "feature_folding" via package "Padre::Config" at /home/sewi/padre/Padre/lib/Padre/Wx/Menu/RightClick.pm line 113.


at /home/sewi/padre/Padre/lib/Padre.pm line 249

Padre::run('Padre=HASH(0x9189ee8)') called at /home/sewi/padre/Padre/script/padre line 181

Can't locate object method "feature_folding" via package "Padre::Config" at /home/sewi/padre/Padre/lib/Padre/Wx/Menu/RightClick.pm line 113.
Perl exited with active threads:

5 running and unjoined
0 finished and unjoined
0 running and detached

Sewi and Zenog got it once per person today within a "some time" running instance, but were not able to reproduce it.

feature_folding is defined in Padre::Config and should be there once Padre completed booting.

Change History

comment:1 Changed 3 years ago by Sewi

A workaround came with r15116, but this is no final fix!

comment:2 Changed 3 years ago by Sewi

  • Priority changed from blocker to critical

comment:3 Changed 2 years ago by adamk

  • Status changed from new to closed
  • Resolution set to fixed

Fixed, changed to editor_folding

Note: See TracTickets for help on using tickets.