Opened 3 years ago

Closed 3 years ago

#1276 closed defect (worksforme)

Compilation of padre.exe triggers virus warning

Reported by: Sewi Owned by:
Priority: critical Milestone:
Component: installation Version: 0.86
Keywords: BitDefender antivirus Win32 Cc: dolmen@…

Description (last modified by Sewi)

ln.exe reports "permission denied" for some output dll it tries to write during "perl Makefile.PL".
The reason is BitDefeder? Anti-Virus which reports the dll as false positive as some heuristic match (false, because I don't think padre.exe includes a virus).

Also the cpan upgrade process stuck at "Writing Makefile for Padre", maybe due to the same problem.

I saw this at a client yesterday and were unable to open the ticket earlier, apologies for inaccurate information. Original Version was 0.84 fresh Strawberry install, problem occured during "install Padre" from the Strawberry CPAN client to get 0.86 and was reproducable doing manual perl Makefile.PL

Change History (8)

comment:1 Changed 3 years ago by Sewi

  • Component changed from not classified yet to installation
  • Description modified (diff)
  • Version changed from 0.84 to 0.86

comment:2 Changed 3 years ago by zenogantner

This is a bug of the anti-virus program, not of Padre.

comment:3 Changed 3 years ago by azawawi

It is an issue with BitDefender? heuristics algorithm. We are using gcc toolchain to compile padre.exe. Nothing fancy.

comment:4 Changed 3 years ago by Sewi

Sure, it's a BitDefender? problem, but they won't fix it unless we send in an false positive report with as much details as possible.
I don't have access to the failing computer and don't even have any Windows left, but maybe someone knows someone using Bitdefender who could gather the information for us.

Question for Padre is, do we need/want to compile padre.exe on Windows every time?

comment:5 Changed 3 years ago by dolmen

We are compiling Padre.exe at installation time because the padre.exe is dynamically linked to the Perl DLL. We want it to work with any Perl version, past or future, so distributing a binary would not be a solution.

It would be interesting to see what happens if you bring the compiled Padre.exe from another machine and try to execute it. I would like to know (for my personal knowledge, not thinking that it could really help to solve the problem) if BitDefender? doesn't like Padre.exe or if it doesn't like that the linker writes into a .exe.
You could also try to compile a simple .exe on that machine :

int main()
{
    printf("Hello, world!\n");
}
C:\Users>gcc -o hello.exe hello.c
C:\Users>hello.exe

comment:6 Changed 3 years ago by dolmen

  • Cc dolmen@… added
  • Keywords BitDefender antivirus Win32 added

comment:7 Changed 3 years ago by Sewi

It's not the padre.exe itself but some (intermediate?) dll the linker is trying to write.

comment:8 Changed 3 years ago by azawawi

  • Resolution set to worksforme
  • Status changed from new to closed

Anti-virus tools use different heuristics algorithms. So you cannot really realistically test for all of them.

Works for me under AVG Home and Symantec Enterprise.

Thanks :)

Note: See TracTickets for help on using tickets.