Opened 3 years ago

Closed 3 years ago

#1282 closed defect (invalid)

Wx::Scintilla v0.21_02 and TABS

Reported by: bowtie Owned by: azawawi
Priority: major Milestone:
Component: Syntax Highlighting Version: 0.87
Keywords: Tab Cc:

Description

Wx::Scintilla 0.21_02

since using above I have noticed that the first TAB is always 8 charters wide

subsequent Tabs are as defined in Tool -> Prefs

Change History (6)

comment:1 Changed 3 years ago by azawawi

Could you please provide me with a step-by-step scenario to replicate it?

comment:2 Changed 3 years ago by bowtie

sorry I don't have a step by step for you,

it's just an observation

if you think it is nothing to do with Wx::Scintilla 0.21_02

please close ticket with

not a bug

or

can not reproduce

comment:3 Changed 3 years ago by azawawi

  • Resolution set to cannot reproduce
  • Status changed from new to closed

Cannot reproduce. Please reopen if you are able to find a scenario.

Thanks,
Ahmad M. Zawawi

comment:4 Changed 3 years ago by bowtie

  • Resolution cannot reproduce deleted
  • Status changed from closed to reopened

in Padre::Wx::menu::Run

when copying $self->AppendSeparator?;

to new line

then TAB

I get 8 spaces, rather than my normal 4

comment:5 Changed 3 years ago by bowtie

If you apply #1202 manually you should see the tab issue

comment:6 Changed 3 years ago by azawawi

  • Resolution set to invalid
  • Status changed from reopened to closed

Just checked it without Wx::Scintilla and it is the same behavior. So this is not not Wx::Scintilla related. I suppose we need to open a new ticket for Padre.

Note: See TracTickets for help on using tickets.