Opened 3 years ago

Closed 3 years ago

#1283 closed defect (fixed)

Downward scrolling causes every 3rd line to blank, intermittently, but consistently.

Reported by: submersible_toaster Owned by:
Priority: major Milestone:
Component: editor Version: 0.76
Keywords: Cc:

Description

<submersible_mib>: mib_806otp - please state your bug anyway
<ccjar>: Changed to ccjar... I updated Padre to as far as 0.76 (current Ubuntu release level). Once I did, when scrolling up in my code using the scroll wheel, approximately every 3rd line is blanked. I say approximately as it is not a perfect overlay of a line.
<ccjar>: I can click into the code space and the lines (most of them) will clear up.
<ccjar>: Sometimes they'll just clear on their own, though most often not.
<submersible_mib>: very odd . Is this ubuntu 10.10 or 11.04
<ccjar>: 11.04
<Alias>: Sounds like a scintilla bug
<submersible_mib>: ccjar: we've seen some similar things in the past - often they don't persist.
<ccjar>: Happy to pursue that direction as well.
<ccjar>: How do you mean, "often they don't pesist"
<ccjar>: er persist
<submersible_mib>: difficult to reproduce ?
<ccjar>: Not at all
<ccjar>: Absolutely consistent
<submersible_mib>: ccjar: could you pls experiment with different file types ; ie - does this occur with a .pl file , but not with .html or other mimetypes
<ccjar>: submersible_mib: Happy to. Will report back shortly
<submersible_mib>: ty
<ccjar>: submersible_mib: Same with html. Looking for others...
<submersible_mib>: ccjar: don't bother .. it's likely all file types
<ccjar>: k
<submersible_mib>: ccjar: are you able to install a local newer copy of padre with local::lib or similar
<ccjar>: I can give it a try
<ccjar>: biab
<submersible_mib>: ccjar: nothing leaps out of the Changes as obviously fixing something like that.
<submersible_mib>: there were some bizarre problems with ubuntu wxperl and 10.10 ... I wonder if there are still issues
<ccjar>: submersible_mib: Get compilation errors when trying to run latest version. Troubleshooting...
<ccjar>: Looking for the XS file to check initialization params...
<ccjar>: submersible_mib: wicked headache is hampering forward progress.
<ccjar>: submersible_mib: As part of correcting my problem here (using a hammer instead of a scalpel since my head is pounding), I removed and reinstalled the curruent Ubuntu version (0.76). I'm now seeing the lines blank fleetingly, then restore.
<ccjar>: I've only seen it stay twice. a mouse click or scroll movement upward cleared them.
<submersible_mib>: ccjar: do you have code folding enabled ( View menu )
<ccjar>: checking
<ccjar>: (I think so
<ccjar>: Actually, no, I don't
<submersible_mib>: probably not that then.
<tome>: sup all
<submersible_mib>: OK - I think it probably deserves a ticket - if it's broken in ubuntu - despite the old(er) version.

Change History (6)

comment:1 Changed 3 years ago by submersible_toaster

  • Summary changed from Upward scrolling causes every 3rd line to blank, intermittently, but consistently. to Downward scrolling causes every 3rd line to blank, intermittently, but consistently.

comment:2 Changed 3 years ago by szabgab

Isn't this the issue with Unity that was reported earlier as well? Does this appear when using "Classic" as well?

comment:3 Changed 3 years ago by submersible_toaster

Is there another ticket for this ?

comment:4 Changed 3 years ago by bowtie

this fix was applied by garu

works for unity and classic

user needs to upgrade to latest padre

this ticket should be closed

comment:5 Changed 3 years ago by bowtie

Transparent fix that does not need changed on the user's computer. Fixed from within Padre at r14398.

comment:6 Changed 3 years ago by bowtie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.