Opened 3 years ago

Closed 3 years ago

#1293 closed defect (fixed)

task signal test failed during CPAN Upgrade (0.86 to 0.88)

Reported by: vrobin Owned by:
Priority: blocker Milestone:
Component: not classified yet Version: 0.88
Keywords: cpan test task signal Cc:

Description

cpan upgrade Padre failed because of this failed test:

t/27_task_signal.t ......... 15/16
# Failed test 'No threads'
# at t/27_task_signal.t line 74.
# got: '1'
# expected: '0'
# Looks like you failed 1 test of 16.
t/27_task_signal.t ......... Dubious, test returned 1 (wstat 256, 0x100)

System is an ubuntu:
Linux x40 2.6.32-33-generic #71-Ubuntu SMP Wed Jul 20 17:30:40 UTC 2011 i686 GNU/Linux
Ubuntu 10.04.3 LTS

Perl and wx versions:
This is perl, v5.10.1 (*) built for i486-linux-gnu-thread-multi

Wx Version=(0.9901) wxWidgets 2.8.10 unicode=(1)

Full log below:

cpan[5]> upgrade Padre

Package namespace installed latest in CPAN file
Padre 0.86 0.88 PLAVEN/Padre-0.88.tar.gz
Running install for module 'Padre'
Running make for P/PL/PLAVEN/Padre-0.88.tar.gz

Has already been unwrapped into directory /root/.cpan/build/Padre-0.88-99tNKs
Has already been made

Running make test
blib/lib/auto/share/dist/Padre/locale -> blib/lib/auto/share/dist/Padre/locale
blib/lib/auto/share/dist/Padre/locale/ko.po -> blib/lib/auto/share/dist/Padre/locale/ko.mo
blib/lib/auto/share/dist/Padre/locale/cz.po -> blib/lib/auto/share/dist/Padre/locale/cz.mo
blib/lib/auto/share/dist/Padre/locale/no.po -> blib/lib/auto/share/dist/Padre/locale/no.mo
blib/lib/auto/share/dist/Padre/locale/hu.po -> blib/lib/auto/share/dist/Padre/locale/hu.mo
blib/lib/auto/share/dist/Padre/locale/he.po -> blib/lib/auto/share/dist/Padre/locale/he.mo
blib/lib/auto/share/dist/Padre/locale/de.po -> blib/lib/auto/share/dist/Padre/locale/de.mo
blib/lib/auto/share/dist/Padre/locale/it-it.po -> blib/lib/auto/share/dist/Padre/locale/it-it.mo
blib/lib/auto/share/dist/Padre/locale/nl-nl.po -> blib/lib/auto/share/dist/Padre/locale/nl-nl.mo
blib/lib/auto/share/dist/Padre/locale/es-es.po -> blib/lib/auto/share/dist/Padre/locale/es-es.mo
blib/lib/auto/share/dist/Padre/locale/pl.po -> blib/lib/auto/share/dist/Padre/locale/pl.mo
blib/lib/auto/share/dist/Padre/locale/fa.po -> blib/lib/auto/share/dist/Padre/locale/fa.mo
blib/lib/auto/share/dist/Padre/locale/zh-tw.po -> blib/lib/auto/share/dist/Padre/locale/zh-tw.mo
blib/lib/auto/share/dist/Padre/locale/ar.po -> blib/lib/auto/share/dist/Padre/locale/ar.mo
blib/lib/auto/share/dist/Padre/locale/fr-fr.po -> blib/lib/auto/share/dist/Padre/locale/fr-fr.mo
blib/lib/auto/share/dist/Padre/locale/ru.po -> blib/lib/auto/share/dist/Padre/locale/ru.mo
blib/lib/auto/share/dist/Padre/locale/zh-cn.po -> blib/lib/auto/share/dist/Padre/locale/zh-cn.mo
blib/lib/auto/share/dist/Padre/locale/tr.po -> blib/lib/auto/share/dist/Padre/locale/tr.mo
blib/lib/auto/share/dist/Padre/locale/ja.po -> blib/lib/auto/share/dist/Padre/locale/ja.mo
blib/lib/auto/share/dist/Padre/locale/pt-br.po -> blib/lib/auto/share/dist/Padre/locale/pt-br.mo
-blib/lib/auto/share/dist/Padre/locale/messages.pot
make[1]: Entering directory `/root/.cpan/build/Padre-0.88-99tNKs/winxs'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/root/.cpan/build/Padre-0.88-99tNKs/winxs'
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'inc', 'blib/lib', 'blib/arch')" t/*.t
t/01-load.t ................ 1/37 # Tests find Wx: 0.9901 wxWidgets 2.8.10
t/01-load.t ................ ok
t/02-new.t ................. ok
t/03-wx.t .................. skipped: Sometimes fails for unknown reasons, skipping for release till fixed
t/04-config.t .............. ok
t/05-project.t ............. ok
t/06-utils.t ............... ok
t/07-version.t ............. ok
t/08-style.t ............... ok
t/13-wx2.t ................. ok
t/14-warnings.t ............ ok
t/15-locale.t .............. 1/7 11:18:14: Error: Cannot set locale to 'de_DE'.
t/15-locale.t .............. ok
t/16-messages.t ............ ok
t/20_task_queue.t .......... ok
t/21_task_thread.t ......... ok
t/22_task_worker.t ......... ok
t/23_task_chain.t .......... ok
t/24_task_master.t ......... ok
t/25_task_handle.t ......... ok
t/26_task_eval.t ........... ok
t/27_task_signal.t ......... 15/16
# Failed test 'No threads'
# at t/27_task_signal.t line 74.
# got: '1'
# expected: '0'
# Looks like you failed 1 test of 16.
t/27_task_signal.t ......... Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/16 subtests
t/28_task_manager.t ........ ok
t/40-perl.t ................ ok
t/41-perl-project.t ........ ok
t/42-perl-project-temp.t ... ok
t/43-perl-utils.t .......... ok
t/44-perl-syntax.t ......... ok
t/45-perl-functionlist.t ... ok
t/50-browser.t ............. skipped: Cannot run as root
t/60-db.t .................. ok
t/61-directory-path.t ...... ok
t/70-document.t ............ ok
t/72-dialog-html.t ......... ok
t/73-display.t ............. ok
t/74-history-combobox.t .... ok
t/75-autocomplete.t ........ ok
t/76-preferences.t ......... ok
t/80-newline.t ............. ok
t/81-search.t .............. ok
t/82-plugin-manager.t ...... ok
t/83-autosave.t ............ ok
t/85-commandline.t ......... ok
t/90-autocomplete.t ........ ok
t/91-vi.t .................. ok
t/92-padre-file.t .......... ok
t/93-padre-filename-win.t .. ok
t/94-padre-file-remote.t ... ok
t/95-search_and_replace.t .. ok

Test Summary Report


t/27_task_signal.t (Wstat: 256 Tests: 16 Failed: 1)

Failed test: 15
Non-zero exit status: 1

Files=47, Tests=1036, 63 wallclock secs ( 0.38 usr 0.19 sys + 33.02 cusr 2.15 csys = 35.74 CPU)
Result: FAIL
Failed 1/47 test programs. 1/1036 subtests failed.
make: * [test_dynamic] Error 255

PLAVEN/Padre-0.88.tar.gz
make test -- NOT OK

hint to see the cpan-testers results for installing this module, try:

reports PLAVEN/Padre-0.88.tar.gz

Running make install

make test had returned bad status, won't install without force

Failed during this command:

PLAVEN/Padre-0.88.tar.gz : make_test NO

cpan[9]> upgrade Padre::Role::Task

Package namespace installed latest in CPAN file
Padre::Role::Task 0.86 0.88 PLAVEN/Padre-0.88.tar.gz
Running install for module 'Padre::Role::Task'
Running make for P/PL/PLAVEN/Padre-0.88.tar.gz

Has already been unwrapped into directory /root/.cpan/build/Padre-0.88-99tNKs
Has already been made

Running make test
blib/lib/auto/share/dist/Padre/locale -> blib/lib/auto/share/dist/Padre/locale
blib/lib/auto/share/dist/Padre/locale/ko.po -> blib/lib/auto/share/dist/Padre/locale/ko.mo
blib/lib/auto/share/dist/Padre/locale/cz.po -> blib/lib/auto/share/dist/Padre/locale/cz.mo
blib/lib/auto/share/dist/Padre/locale/no.po -> blib/lib/auto/share/dist/Padre/locale/no.mo
blib/lib/auto/share/dist/Padre/locale/hu.po -> blib/lib/auto/share/dist/Padre/locale/hu.mo
blib/lib/auto/share/dist/Padre/locale/he.po -> blib/lib/auto/share/dist/Padre/locale/he.mo
blib/lib/auto/share/dist/Padre/locale/de.po -> blib/lib/auto/share/dist/Padre/locale/de.mo
blib/lib/auto/share/dist/Padre/locale/it-it.po -> blib/lib/auto/share/dist/Padre/locale/it-it.mo
blib/lib/auto/share/dist/Padre/locale/nl-nl.po -> blib/lib/auto/share/dist/Padre/locale/nl-nl.mo
blib/lib/auto/share/dist/Padre/locale/es-es.po -> blib/lib/auto/share/dist/Padre/locale/es-es.mo
blib/lib/auto/share/dist/Padre/locale/pl.po -> blib/lib/auto/share/dist/Padre/locale/pl.mo
blib/lib/auto/share/dist/Padre/locale/fa.po -> blib/lib/auto/share/dist/Padre/locale/fa.mo
blib/lib/auto/share/dist/Padre/locale/zh-tw.po -> blib/lib/auto/share/dist/Padre/locale/zh-tw.mo
blib/lib/auto/share/dist/Padre/locale/ar.po -> blib/lib/auto/share/dist/Padre/locale/ar.mo
blib/lib/auto/share/dist/Padre/locale/fr-fr.po -> blib/lib/auto/share/dist/Padre/locale/fr-fr.mo
blib/lib/auto/share/dist/Padre/locale/ru.po -> blib/lib/auto/share/dist/Padre/locale/ru.mo
blib/lib/auto/share/dist/Padre/locale/zh-cn.po -> blib/lib/auto/share/dist/Padre/locale/zh-cn.mo
blib/lib/auto/share/dist/Padre/locale/tr.po -> blib/lib/auto/share/dist/Padre/locale/tr.mo
blib/lib/auto/share/dist/Padre/locale/ja.po -> blib/lib/auto/share/dist/Padre/locale/ja.mo
blib/lib/auto/share/dist/Padre/locale/pt-br.po -> blib/lib/auto/share/dist/Padre/locale/pt-br.mo
-blib/lib/auto/share/dist/Padre/locale/messages.pot
make[1]: Entering directory `/root/.cpan/build/Padre-0.88-99tNKs/winxs'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/root/.cpan/build/Padre-0.88-99tNKs/winxs'
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'inc', 'blib/lib', 'blib/arch')" t/*.t
t/01-load.t ................ 1/37 # Tests find Wx: 0.9901 wxWidgets 2.8.10
t/01-load.t ................ ok
t/02-new.t ................. ok
t/03-wx.t .................. skipped: Sometimes fails for unknown reasons, skipping for release till fixed
t/04-config.t .............. ok
t/05-project.t ............. ok
t/06-utils.t ............... ok
t/07-version.t ............. ok
t/08-style.t ............... ok
t/13-wx2.t ................. ok
t/14-warnings.t ............ ok
t/15-locale.t .............. 1/7 11:24:27: Error: Cannot set locale to 'de_DE'.
t/15-locale.t .............. ok
t/16-messages.t ............ ok
t/20_task_queue.t .......... ok
t/21_task_thread.t ......... ok
t/22_task_worker.t ......... ok
t/23_task_chain.t .......... ok
t/24_task_master.t ......... ok
t/25_task_handle.t ......... ok
t/26_task_eval.t ........... ok
t/27_task_signal.t ......... 15/16
# Failed test 'No threads'
# at t/27_task_signal.t line 74.
# got: '1'
# expected: '0'
# Looks like you failed 1 test of 16.
t/27_task_signal.t ......... Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/16 subtests
t/28_task_manager.t ........ ok
t/40-perl.t ................ ok
t/41-perl-project.t ........ ok
t/42-perl-project-temp.t ... ok
t/43-perl-utils.t .......... ok
t/44-perl-syntax.t ......... ok
t/45-perl-functionlist.t ... ok
t/50-browser.t ............. skipped: Cannot run as root
t/60-db.t .................. ok
t/61-directory-path.t ...... ok
t/70-document.t ............ ok
t/72-dialog-html.t ......... ok
t/73-display.t ............. ok
t/74-history-combobox.t .... ok
t/75-autocomplete.t ........ ok
t/76-preferences.t ......... ok
t/80-newline.t ............. ok
t/81-search.t .............. ok
t/82-plugin-manager.t ...... ok
t/83-autosave.t ............ ok
t/85-commandline.t ......... ok
t/90-autocomplete.t ........ ok
t/91-vi.t .................. ok
t/92-padre-file.t .......... ok
t/93-padre-filename-win.t .. ok
t/94-padre-file-remote.t ... ok
t/95-search_and_replace.t .. ok

Test Summary Report


t/27_task_signal.t (Wstat: 256 Tests: 16 Failed: 1)

Failed test: 15
Non-zero exit status: 1

Files=47, Tests=1036, 63 wallclock secs ( 0.43 usr 0.14 sys + 32.83 cusr 2.25 csys = 35.65 CPU)
Result: FAIL
Failed 1/47 test programs. 1/1036 subtests failed.
make: * [test_dynamic] Error 255

PLAVEN/Padre-0.88.tar.gz
make test -- NOT OK

hint to see the cpan-testers results for installing this module, try:

reports PLAVEN/Padre-0.88.tar.gz

Running make install

make test had returned bad status, won't install without force

Failed during this command:

PLAVEN/Padre-0.88.tar.gz : make_test NO

Change History (7)

comment:1 Changed 3 years ago by Sewi

  • Priority changed from major to blocker

comment:2 follow-up: Changed 3 years ago by dolmen

Could not reproduce. Ubuntu Natty, Wx 2.8.11 (different from yours), Alien::wxWidgets 0.51.

The last line before the failing test is "Time::HiRes::sleep(5)". Could you try to raise the value and see if that is still failing?

comment:3 Changed 3 years ago by dolmen

$ cpan
cpan> look Padre
$ perl Makefile.PL
$ make
$ prove -Ilib t/27_task_signal.t
# Verify that it fails
# Edit t/27_task_signal.t and patch it
$ prove -Ilib t/27_task_signal.t

comment:4 in reply to: ↑ 2 Changed 3 years ago by vrobin

Replying to dolmen:

Could not reproduce. Ubuntu Natty, Wx 2.8.11 (different from yours), Alien::wxWidgets 0.51.

The last line before the failing test is "Time::HiRes::sleep(5)". Could you try to raise the value and see if that is still failing?

I changed the sleep value to 15... the problem is still there... return value is still 1 instead of 0

version complement:
Module = Alien::wxWidgets (MDOOTSON/Alien-wxWidgets-0.52.tar.gz)
Module = Wx (MDOOTSON/Wx-0.9901.tar.gz)
as reported earlier, wxWidgets 2.8.10 unicode=(1)

Last edited 3 years ago by vrobin (previous) (diff)

comment:5 Changed 3 years ago by Sewi

Reproduced from trunk (same test script).

Raised time to 50 seconds but still failing.

comment:6 Changed 3 years ago by Sewi

Workaround installed in r15468

Developer test added in r15469

comment:7 Changed 3 years ago by Sewi

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.