Ticket #1294 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

Space in text field for pref "editor_right_margin_colum" stops Padre

Reported by: dolmen Owned by:
Priority: critical Milestone:
Component: Preference System Version: 0.90
Keywords: crash numeric pref editor_right_margin_column Cc:

Description

How to reproduce:

  1. Tools > Preferences > Appearance
  2. Text field for "Show right margin at column"
  3. Type a space after the value (default is "80")
  4. Padre stops with the following message:

Setting 'editor_right_margin_column' to non-posint '80 ' at /home/dolmen/Code/Perl/cpan/Padre/lib/Padre/Wx/Dialog/Preferences.pm line 258

The preference dialog should filter for non-latin-decimal characters in this field.

Change History

comment:1 Changed 2 years ago by markstos

I"ve confirmed this crasher. It is still present in Padre 0.90. There's another variation besides adding a space at the end.

Say you want to replace "80" with "72". Just delete the "80" in the field. Before you can even start to type "72" to replace it, Padre will have crashed.

comment:2 Changed 2 years ago by markstos

  • Priority changed from minor to critical
  • Version changed from 0.89 to 0.90

If the system will let me, I'm also raising priority to "critical". This is a data-loss issue.

It's the reason I'm returning to Gvim for now. I need my text editor to be reliabe.

comment:3 Changed 2 years ago by adamk

  • Status changed from new to closed
  • Resolution set to fixed

This is now fixed. The initial fix is a little scrappy, but it will do.

Note: See TracTickets for help on using tickets.