Opened 3 years ago

Closed 3 years ago

#1306 closed defect (fixed)

Locale: move 'fr-fr' to just 'fr'

Reported by: dolmen Owned by: dolmen
Priority: minor Milestone:
Component: installation Version: 0.90
Keywords: fr locale translation migration upgrade Cc: jquelin@…

Description

The translation for the french language has initially been created as 'fr-fr' (French / France).
However, the 'France' specific part is not needed: we do not expect to build translations specific to Belgium, Swiss, african countries, Haïti, Canada... There are not really variations in written french (as far as software translation is concerned) and also not much workforce to do it anyway. Debian for example has only 'fr'.

The fix would seem to be easy: just rename *-fr-fr.po to *-fr.po.

However the issue is in upgrade: what will happen if after install the user has both -fr-fr.mo and -fr.mo? I think we should ensure that any old -fr-fr.po is removed at install time. The issue is not only for the Padre core, but also for plugins.

This ticket is so opened for discussion on those matters before doing the move. As I don't know much Module::Install, I would like some feedback on what is possible to do in the Makefile.PL.

Note: this issue is also probably relevant for other languages: it, de, es, nl...

Change History (3)

comment:1 Changed 3 years ago by dolmen

Here are some additional references on why the language code 'fr' should be used instead of 'fr-fr':

comment:2 Changed 3 years ago by dolmen

  • Priority changed from major to minor
  • Status changed from new to assigned
  • Summary changed from Locale: move 'fr-fr' to just 'fr' (upgrade issue) to Locale: move 'fr-fr' to just 'fr'
  • Version changed from 0.88 to 0.90

Upgrade is not an issue because the .mo file used is selected based on the language mapping table in Padre::Locale. If we update the language table to use 'fr' instead of 'fr-fr', only 'fr' will be used even if a 'fr-fr.mo' exists.

comment:3 Changed 3 years ago by dolmen

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in r15809.

Note: See TracTickets for help on using tickets.