Ticket #1320 (closed defect: not a bug)

Opened 3 years ago

Last modified 3 years ago

crash: Can't locate object method "SetIndicatorCurrent"

Reported by: szabgab Owned by:
Priority: critical Milestone:
Component: not classified yet Version: 0.91
Keywords: Cc:

Description

just upgraded to r16175 on Windows and soon after starting I got a crash:

C:\work\padre\Padre>perl dev
Can't locate object method "SetIndicatorCurrent?" via package "Padre::Wx::Editor" at C:/work/padre/Padre/lib/Padre/Wx/Editor.pm line 1757.
Perl exited with active threads:

6 running and unjoined
0 finished and unjoined
0 running and detached

Change History

comment:1 Changed 3 years ago by szabgab

  • Version changed from 0.90 to 0.91

comment:2 Changed 3 years ago by azawawi

'cpan .' to get the latest scintilla? :)

comment:3 Changed 3 years ago by szabgab

I can now reproduce it:

  1. open a perl file. try to mark some section:
  2. ctrl+shift+rightarrow
  3. crash

comment:4 Changed 3 years ago by szabgab

  • Status changed from new to closed
  • Resolution set to not a bug

Upgrading the required prereq to Wx::Scintilla 0.28 solved the problem.
User error.
Sorry for the noise.

comment:5 Changed 3 years ago by azawawi

No problem. Actually i was thinking that we need a hard-prerequisite like Alien::wxWidgets when upgrading Padre.

Note: See TracTickets for help on using tickets.