Ticket #1334 (closed enhancement: not relevant)

Opened 3 years ago

Last modified 2 years ago

Syntax checker could be slower

Reported by: ktaragorn Owned by:
Priority: major Milestone:
Component: Syntax Checking Version: 0.90
Keywords: Cc:

Description

The syntax checking as it stands right now, checks too fast, i pause for thought for a second and its checking, causing a brief but noticable lag on my machine atleast. This need not be so eager..

If i am typing on a line without a semi colon, i think the syntax checking can be slowed down to 5 seconds or more.. i.e. its usefulness is mainly only after ur done typing the line.

It is also unstable and seems to crash on certain files, i will file another ticket if i find a reproducible example of this.

Change History

comment:1 Changed 3 years ago by szabgab

Isn't there a configuration option at least for the wait period? If not there should be.

comment:2 Changed 3 years ago by ktaragorn

I could not locate any such option to control it, but a flat option might not be as useful as the possible behavior i mentioned, but might be a start.

Also i found a test case to crash the release version using syntax checker, however this feature seems to be heavily worked on in the trunk and no longer crashes.. anyway here is the sample proj just for completeness

use MooseX::Declare;

class test {

   method hel
   method world(){}
}

in this case if i type the world method first and then type hello above it and stop at this point, release segfaults. This is on Ubuntu 11.04

comment:3 Changed 3 years ago by azawawi

So is it 100% fixed in trunk?

comment:4 Changed 3 years ago by ktaragorn

The bug is (and was) fixed in trunk. The problem that is too fast and consequently distracting is still there.

comment:5 Changed 3 years ago by azawawi

In trunk, you have editor_dwell which tell you when the editor is going to refresh panels including syntax after a change. Default value is 500 milliseconds.

comment:6 Changed 3 years ago by azawawi

Hi, did you try editor_dwell?

comment:7 Changed 2 years ago by azawawi

  • Status changed from new to closed
  • Resolution set to not relevant
Note: See TracTickets for help on using tickets.