Ticket #1370 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

Debug::Client, @list context request fails against perl-5.15.6 (3 of n)

Reported by: bowtie Owned by: bowtie
Priority: minor Milestone:
Component: Debug::Client Version: 0.93
Keywords: Cc:

Description

I have started sorting this out, but will not add to trunk until Debug2 is released and there has been some feedback.

As this affects bleeding edge code only.

It will also causes knock on changes to wx-panel-debugger

Change History

comment:1 Changed 2 years ago by bowtie

  • Component changed from not classified yet to Debug::Client

comment:2 Changed 2 years ago by bowtie

  • Version changed from 0.92 to 0.93

comment:3 Changed 2 years ago by bowtie

  • Summary changed from Debug::Client, @list request fails against perl-5.15.6 (3 of n) to Debug::Client, @list context request fails against perl-5.15.6 (3 of n)

version 0.17_04 has an issue with several bleeedperl versions see http://matrix.cpantesters.org/?dist=Debug-Client%200.17_04

switched to tdd for testing in version 0.17_05.

tested against perl 5.15.7 and all is ok, see http://matrix.cpantesters.org/?dist=Debug-Client%200.17_05

until debugger.pm is updated to use the tdd logic, I will stay with dev releases, of Debug::Client

comment:4 Changed 2 years ago by bowtie

  • Status changed from new to closed
  • Resolution set to fixed

applied to debug2 in r18644 now as it uses debug-client 0.18

Note: See TracTickets for help on using tickets.