Ticket #1377 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

Search dialog claims unsuccessful search even though it was successful

Reported by: zenogantner Owned by: alias
Priority: critical Milestone:
Component: not classified yet Version: 0.93
Keywords: Cc:

Description

How to reproduce:

  1. Load file, e.g. share/locale/de.po from the Padre source code
  2. Hit Ctrl-f Ctrl-F to fire up the search dialog
  3. Enter a term that occurs in the file, e.g. "perl"

Result: First occurrence of the term is highlighted, while a message "No matches found" is displayed.

See attached screenshot

Attachments

padre-search.png (84.8 KB) - added by zenogantner 2 years ago.

Change History

Changed 2 years ago by zenogantner

comment:1 Changed 2 years ago by bowtie

just tried this against r17844

no info dialog

will try with latest

comment:2 Changed 2 years ago by bowtie

just repeated with r17848, do you want a png in ticket?
same result

comment:3 Changed 2 years ago by bowtie

Padre 0.93

Core...
                  osname linux
                archname i686-linux-thread-multi
            Distribution Ubuntu 11.04 
                  Kernel 2.6.38-13-generic
                    Perl 5.14.2
                 Threads 6
                     RAM (unsupported)
Wx...
                      Wx 0.9903
               WxWidgets 2.8.11
                 unicode 1
        Alien::wxWidgets 0.54
 Wx::Perl::ProcessStream 0.30
           Wx::Scintilla 0.36
Other...
                     PPI 1.215
           Debug::Client 0.17_04
                  Config /usr/src/Padre/Padre/.padre
Last edited 2 years ago by zenogantner (previous) (diff)

comment:4 Changed 2 years ago by zenogantner

My data:

                   Padre 0.93
Core...
                  osname linux
                archname i486-linux-gnu-thread-multi
            Distribution Ubuntu 10.04.3 LTS 
                  Kernel 2.6.32-38-generic
                    Perl 5.10.1
                 Threads 2
                     RAM 101.7MB
Wx...
                      Wx 0.9901
               WxWidgets 2.8.10
                 unicode 1
        Alien::wxWidgets 0.51
 Wx::Perl::ProcessStream 0.30
           Wx::Scintilla 0.34
Other...
                     PPI 1.215
           Debug::Client 0.16
                  Config /mnt/data/src/padre/Padre/.padre
Last edited 2 years ago by zenogantner (previous) (diff)

comment:5 Changed 2 years ago by adamk

  • Status changed from new to closed
  • Resolution set to fixed

Fixed, nobody else was seeing it because they probably use the config "Show info messages on status bar" setting, which was hiding the popup.

Note: See TracTickets for help on using tickets.