Opened 6 years ago

Closed 6 years ago

#146 closed defect (fixed)

Odd behavoir when copying and pasting.

Reported by: simcop2387 Owned by:
Priority: major Milestone:
Component: editor Version: 0.16
Keywords: Cc: simcop2387@…

Description

When attempting to paste new text on top of some old stuff i did this.

first (obviously) i copied the new text.
second, i selected the text i wanted to replace (with keyboard, don't think that matters though).
third, hit control+v and the new text was pasted BUT it was inserted either before or after the old text (depending on where the cursor was), rather than the behavior of just about every other editor i've used where it would replace the text selected rather than ignore the selection.

marking as a defect since i don't know any better.

Change History (3)

comment:1 follow-up: Changed 6 years ago by szabgab

I tried to reproduce it but I have not managed to do so on Ubuntu 8.10.

Can you (reliably) reproduce it ?

What operating system are you using and what is the version of wxWidgets ? (See Padre/Help/About? )

comment:2 in reply to: ↑ 1 Changed 6 years ago by simcop2387

  • Version changed from 0.17 to 0.16

adding OS versions and wx widgets, this was with 0.16, forgot to fill that out correctly before (i'll grab 0.17 from svn later today).

Linux andromeda128 2.6.27-gentoo #1 SMP PREEMPT Sat Nov 1 15:31:26 EDT 2008 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4800+ AuthenticAMD GNU/Linux

Wx.pm is version 0.88, wx libraries appear to be 2.8.8

comment:3 Changed 6 years ago by simcop2387

  • Resolution set to fixed
  • Status changed from new to closed

appears to be fixed in 0.17

Note: See TracTickets for help on using tickets.