Ticket #1480 (reopened defect)

Opened 15 months ago

Last modified 4 months ago

debugger hangs

Reported by: vsespb Owned by: bowtie
Priority: major Milestone:
Component: Debugger for Perl 5 Version: 0.96
Keywords: Cc:

Description

I launch debugger and padre just hangs, until I kill it with killall padre.

Change History

comment:1 Changed 15 months ago by bowtie

Hi, please add the following informations:

http://padre.perlide.org/trac/wiki/Tickets

comment:2 Changed 15 months ago by vsespb

http://padre.perlide.org/trac/wiki/Tickets

You are using the latest released version of Padre

latest version available on CPAN - 0.96

Check if there is already a ticket with the same issue, maybe even fixed in trunk {1}

I've searched http://padre.perlide.org/trac/search?q=debugger
I don't see possible duplicates.
This one http://padre.perlide.org/trac/ticket/1417 seems different issue

In the report please provide the details of your Operating system, Perl version number, version of Wx and wxWidgtes

                   Padre 0.96
Core...
                  osname linux
                archname x86_64-linux-gnu-thread-multi
            Distribution Ubuntu 10.04.4 LTS 
                  Kernel 2.6.38-16-generic
                    Perl 5.10.1
                 Threads 8
                     RAM 796.3MB
Wx...
                      Wx 0.9916
               WxWidgets 2.8.10
                 unicode 1
        Alien::wxWidgets 0.51
 Wx::Perl::ProcessStream 0.30
           Wx::Scintilla 0.39
Other...
                     PPI 1.215
           Debug::Client 0.20
                  Config /home/vse/.local/share/.padre

In addition please describe how did you install Padre?

CPAN

Please try to describe clearly how we can reproduce the bug

Open any perl file, even file with just two characters - "1;", hit "Debug -> Lauch debugger". GUI will hang.

Last edited 15 months ago by bowtie (previous) (diff)

comment:3 Changed 15 months ago by bowtie

ok,

while I emulate your environment

can you run - http://padre.perlide.org/trac/attachment/wiki/Features/Perl5Debugger/test.pl

make sure you can run the script from within padre, and there are no errors before running debugger, use the features syntax checker

comment:4 Changed 15 months ago by bowtie

You have looked at the companion wiki - http://padre.perlide.org/trac/wiki/Features/Perl5Debugger

comment:5 Changed 15 months ago by vsespb

Syntax checker is OK.
But I actually cannot run it from padre. I cannot run even simple 'print hello world' from padre. I press F5 and nothing happens.. ("Output" window is empty)

comment:6 Changed 15 months ago by vsespb

I've read half of that wiki, but it does not explain why
simple script 'print "Hello World\n";' make Padre hangs

comment:7 Changed 15 months ago by bowtie

ok,

try using external output, see wiki

vsespb do you want to talk on irc - http://padre.perlide.org/contact.html

comment:8 Changed 15 months ago by bowtie

working using the following

                   Padre 0.96
Core...
                  osname linux
                archname i686-linux-thread-multi
            Distribution Ubuntu 12.10 
                  Kernel 3.5.0-22-generic
                    Perl 5.10.1
                 Threads 10
                     RAM 383.5MB
Wx...
                      Wx 0.9916
               WxWidgets 2.8.12
                 unicode 1
        Alien::wxWidgets 0.62
 Wx::Perl::ProcessStream 0.32
           Wx::Scintilla 0.39
Other...
                     PPI 1.215
           Debug::Client 0.20
                  Config /home/kevin/.local/share/.padre

comment:9 Changed 15 months ago by vsespb

Ok, now it's working when I turned _OFF_ "use external window for execution"

So I think bug is it's _hangs_ when "use external window for execution" is ON (And this checkbox is checked by default?)

vsespb do you want to talk on irc

Unfortunately I don't use IRC since 1999, I don't have client and don't remember how to use it.

comment:10 Changed 15 months ago by bowtie

ok, there are lot's of bug fixes to debugger in Padre trunk 0.97

which is soon to be released as padre 0.98

so we can close this ticket now?

comment:11 Changed 15 months ago by bowtie

as for irc use the web client, link on page I gave you

comment:12 Changed 15 months ago by vsespb

so we can close this ticket now?

I don't know - yo're the developer! I you sure there is no bug in trunk - close it.

comment:13 Changed 15 months ago by bowtie

  • Status changed from new to closed
  • Resolution set to fixed

comment:14 Changed 4 months ago by vsespb

just installed padre 1.00
same, debugger hangs, and "use external window for execution"=FALSE fixes this.

comment:15 Changed 4 months ago by vsespb

  • Status changed from closed to reopened
  • Resolution fixed deleted
Note: See TracTickets for help on using tickets.