Opened 11 months ago

Last modified 6 months ago

#1507 new defect

Debugger causing Padre crash - MacOSx

Reported by: ron Owned by: bowtie
Priority: minor Milestone:
Component: Debugger for Perl 5 Version: 0.92
Keywords: OSX, Debugger Cc:

Description (last modified by bowtie)

When i launch the debugger by clicking Step In, the Padre App hangs.
I searched the wiki for similar tickets and found http://padre.perlide.org/trac/ticket/1480
Have followed all of the suggested steps in it, including disabling/enabling external window execution. Padre still hangs when i invoke debugger.

Installation mode- Binary download from padre site
My Configuration - Padre on Mac OS X (mountain lion)

                   Padre 0.92
Core...
                  osname darwin
                archname darwin-thread-multi-2level
                    Perl 5.14.2
                 Threads 3
                     RAM (unsupported)
Wx...
                      Wx 0.9903
               WxWidgets 2.8.12
                 unicode 1
        Alien::wxWidgets 0.54
 Wx::Perl::ProcessStream 0.30
           Wx::Scintilla 0.36
Other...
                     PPI 1.215
                  Config /Users/ronabraham/Library/Application Support/.padre

Attachments (1)

Screen Shot 2013-09-03 at 4.44.18 PM.png (180.9 KB) - added by ron 11 months ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 11 months ago by bowtie

I think you will find this issue has been fixed.

please try with the dev version of Padre r19785

comment:2 Changed 11 months ago by bowtie

  • Version changed from 0.98 to 0.92

comment:3 Changed 11 months ago by ron

Is there a possibility of getting a binary version of these changes any time soon for Os X ?
Else i will have to spend time and install perl again as documented in http://padre.perlide.org/trac/wiki/DownloadMacOSX

comment:4 Changed 11 months ago by ron

Following the last update i have now installed Citrus Perl5.16.3 , DebugClient_029 and Padre 0.98 from source from CPAN.
Now when i launch Padre from the terminal, I am able to set a break point and start the Debugger, however it still causes wxPerl to hang as in the screenshot attached.

I checked the terminal log and found the following message after i launch the debugger.

84:84: syntax error: Expected “"” but found end of script. (-2741)

comment:6 Changed 11 months ago by bowtie

  • Description modified (diff)

comment:7 Changed 11 months ago by ron

ok.
can i know how i can test and confirm this ?
As i've mentioned I have already tried testing by downloading padre source from cpan and it crashes the App.
Maybe i need to look somewhere else for this changeset ?

comment:9 Changed 11 months ago by ron

Hi,
I downloaded the svn source to try this out..
but

$make test

gave me the following result. -> http://pastebin.com/4aSHJvYS

in any case i ran $perl dev and tested the scenario.
i got the same result as in the earlier attachment.

Regards
Ron.

comment:10 Changed 10 months ago by bowtie

sorry for the silly Q,

but you were trying to do:

$ cd padre/Padre
$ perl Makefile.PL      # which will tell about all the missing dependencies of Padre
                        # this may fail if you don't have Module::Install
                        # if so, start cpan and install it with all its prerequisites
$ make
$ make test

so the preceding were successful

comment:11 Changed 10 months ago by ron

Hi,

yes i have run the preliminary steps.
And now i tried it with Module::Install as well.

make test gives me

Test Summary Report
-------------------
t/15_locale.t            (Wstat: 6 Tests: 2 Failed: 0)
  Non-zero wait status: 6
  Parse errors: Bad plan.  You planned 7 tests but ran 2.
Files=79, Tests=2535, 80 wallclock secs ( 0.62 usr  0.20 sys + 33.20 cusr  3.13 csys = 37.15 CPU)
Result: FAIL
Failed 1/79 test programs. 0/2535 subtests failed.
make: *** [test_dynamic] Error 255

Detailed Log ->
http://pastebin.com/YabmA42E

If you want i can copy this into a [separate ticket/mailing list thread] for this installation issue , so that the debugger crash issue can be focused on here ?

Regards
Ron.

comment:12 Changed 6 months ago by ron

hey,

any updates on this ? is there a disk image available for osx ?

Note: See TracTickets for help on using tickets.