#1510 closed defect (invalid)

Ensure usage of File::Spec version 3.2 or higher in Makefile.PL

Reported by: itcharlie Owned by:
Priority: major Milestone:
Component: not classified yet Version: 1.00
Keywords: Cc:

Description

Invalid version format (non-numeric data) at /usr/local/share/perl/5.18.1/Padre/Document.pm line 126.
BEGIN failed--compilation aborted at /usr/local/share/perl/5.18.1/Padre/Document.pm line 126.
Compilation failed in require at /usr/local/share/perl/5.18.1/Padre/Wx/Main.pm line 4115.
Perl exited with active threads:

1 running and unjoined
0 finished and unjoined
0 running and detached

irc screename 'ellcaroc' reported this issue and he was able to fix this problem by omitting the version number. He reported having File::Spec 3.40 installed on his machine.

Please note that this is the original line in trunk for Document.pm:
use File::Spec 3.2 (); # 3.21 needed for volume-safe abs2rel

Because of this bug users are not able to run padre successfully.

Change History (1)

comment:1 Changed 11 months ago by itcharlie

  • Resolution set to invalid
  • Status changed from new to closed

Makefile.PL in trunk aready requires 3.2701 of File::Spec. So I am marking this as an invalid bug.

Note: See TracTickets for help on using tickets.