Ticket #154 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

fails to launch on OS X

Reported by: leedo Owned by:
Priority: critical Milestone:
Component: editor Version: 0.17
Keywords: Mac Cc:

Description

I have installed Padre via CPAN on OS X 10.5.5 with perl 5.10.0 from MacPorts?. I did install the DBI and Mac modules through MacPorts? as well, but the rest of the modules through CPAN.

When I try to launch Padre I see a window open, and I can see a few icons appear very quickly. The window then disappears and I get this error message:

laylward:~ leedo$ padre
laylward:~ leedo$ On Mac OS X please run scripts with the 'wxPerl' interpreter
Can't call method "highlight_braces" on an undefined value at /opt/local/lib/perl5/site_perl/5.10.0/Padre/Wx/MainWindow.pm line 1878.

I have also tried launching padre using wxPerl and get the same error, minus the 'wxPerl' warning. Has anyone else gotten Padre to work on OS X?

Change History

comment:1 Changed 5 years ago by szabgab

Schwern managed to install it.
what version of wxWidgets do you have installed?

try to put a return; on the previous line.

This looks like a bug in Padre.

comment:2 Changed 5 years ago by leedo

I have wxWidgets 2.8.9 installed

I've added the return statement, and things seem to work if I launch it with wxPerl. However, if I launch Padre with perl 5.10 it creates the window but I can not interact with it at all, I can't even focus the window. I don't know much about wxPerl, but maybe Padre should check for wxPerl at install time and use that if it exists.

I do get this warning using both perl and wxPerl:

laylward:~ leedo$ wxPerl /opt/local/bin/padre 
laylward:~ leedo$ Thu Nov 20 09:52:59 laylward.local wxPerl[85186] <Error>: CGContextRestoreGState: invalid context

comment:3 Changed 5 years ago by leedo

A little more research shows that Wx::Perl::ProcessStream? fails the second test in 01-events.t at

my $process = $self->start_process( $cmd );
ok( $process->IsAlive() );

Maybe because it is not spawning the process with 'wxPerl'. I'm not sure if this is related to the original issue or not.

comment:4 Changed 5 years ago by szabgab

  • Keywords Mac added

Could you try with 0.20 force-ing if that test still fails.

comment:5 Changed 5 years ago by leedo

  • Status changed from new to closed
  • Resolution set to fixed

It launches perfectly now. It does throw a few warnings, but I haven't noticed any actual problems yet.

laylward:~ leedo$ padre 
laylward:~ leedo$ Use of uninitialized value in subroutine entry at /opt/local/lib/perl5/site_perl/5.10.0/Padre/Wx/Editor.pm line 730.
Tue Dec  2 16:50:05 laylward.local wxPerl[45422] <Error>: CGContextRestoreGState: invalid context

Thanks!

Note: See TracTickets for help on using tickets.