Ticket #185 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Padre crash when closing files

Reported by: szabgab Owned by:
Priority: major Milestone:
Component: editor Version: trunk
Keywords: Cc: heiko_jansen@…

Description (last modified by szabgab) (diff)

I open several files, then I close them one by one by clicking on [x] on the tab title, If I do it fast enough - before the window gets refreshed padre crashes without anything on the console.

This only seems to happen if the Perl 5 syntax checker is on.

Happens on r2180

Change History

comment:1 follow-up: ↓ 3 Changed 5 years ago by szabgab

  • Version changed from 0.21 to trunk
  • Description modified (diff)

comment:2 in reply to: ↑ description Changed 5 years ago by azawawi

On windows XP Pro & Oct '08 strawberry perl 5.10, you can replicate the same problem by opening all the files in Padre/Padre?/eg and then hold CTRL-W (which closes documents very quickly). Windows will show its usual process crashed dialog and Padre perl.exe process hangs (CTRL-C on the command line does not have any effect). Even End Task from Task manager does not kill it. If you kill the cmd.exe process that spawned it, then it dies.

comment:3 in reply to: ↑ 1 Changed 5 years ago by azawawi

sub update_gui() is the guilty one (line 122) of Padre::Task::SyntaxChecker?. If you comment the lines 199-200; then it wont happen. It seems to be related to C-level and related to scintilla.

comment:4 Changed 5 years ago by azawawi

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in trunk.

# allow one refresh per second.. This prevents possible
# future refresh bugs...

comment:5 Changed 5 years ago by hjansen

  • Cc heiko_jansen@… added
  • Priority changed from critical to major
  • Status changed from closed to reopened
  • Resolution fixed deleted

I can still reproduce the crash with the current r2628.
It happens even when I unchecked the syntax check menu item and restarted Padre to get a completely fresh app.
Just open a dozen or so empty new files and hold CTRL-W.
Happens on Linux/32Bit, Wx 0.89, wxWidgets 2.8.8 (openSUSE 11.1).

comment:6 Changed 5 years ago by szabgab

  • Status changed from reopened to closed
  • Resolution set to fixed

I assume this has been fixed since then. Please reopen if you still see this crash.

Note: See TracTickets for help on using tickets.