Opened 6 years ago

Closed 2 years ago

#192 closed defect (fixed)

Small GDI leak for every undo/redo pair [win32]

Reported by: azawawi Owned by: szabgab
Priority: major Milestone:
Component: editor Version: 0.22
Keywords: Cc:

Description

  1. Open the Task Manager, select the menu View -> Select Columns... and then tick the "GDI Objects" column.
  2. Open a new document and type anything.
  3. Keep pressing undo/redo (CTRL-Z and CTRL-Y).
  4. The "GDI object" value for the perl.exe process should be increasing until you close the document.

Note: This is related to ticket:190

Change History (7)

comment:1 Changed 6 years ago by azawawi

  • Owner set to azawawi
  • Status changed from new to accepted

comment:2 Changed 5 years ago by azawawi

  • Owner changed from azawawi to (none)
  • Status changed from accepted to assigned

comment:3 Changed 3 years ago by wwe

retested with 0.84 on WinXP. The problem is still there. In my installation it doesn't occur on one step undo/redo but only if you undo redo multiple steps (2-3 lines of code in my case).

comment:4 Changed 2 years ago by bowtie

  • Owner changed from (none) to szabgab

comment:5 follow-up: Changed 2 years ago by azawawi

Is this still the case?

comment:6 in reply to: ↑ 5 Changed 2 years ago by wwe

I couldn't reproduce this anymore with Padre 0.94 (Dwimperl 5.14) on WinXP 32bit.

comment:7 Changed 2 years ago by bowtie

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.