Opened 6 years ago

Closed 2 years ago

#204 closed defect (fixed)

Scalars leaked: 1

Reported by: szabgab Owned by: tsee
Priority: major Milestone:
Component: editor Version: trunk
Keywords: bounty Cc:

Description

After closing padre I get the above warning on the command line.
It does not seem to be too serious an issue but better documented. (r2412)

Change History (7)

comment:1 Changed 5 years ago by tsee

For the record: This warning is issued when extra threads are joined. It's a combination of threads and Wx. Tough issue. I'll pay a couple of beers to whoever fixes it.

comment:2 Changed 5 years ago by waxhead

  • Owner set to tsee
  • Status changed from new to assigned

Looks like tsee gets the beers!

This maybe fixed with the work done in the branch and waiting for merge after the 0.56 release.

I'm assigning this one to tsee so it gets closed if it turns out we owe him beers and cheers for solving the Leaking Scalar warning! :)

comment:3 Changed 4 years ago by zenogantner

  • Keywords bounty added

More beer/tea/coffee from me!

comment:4 Changed 3 years ago by gyles19

This issue is still present in 0.90 and can be reproduced with a simple "padre foo" thusly:

+ ulimit -c unlimited
+ LIBC_FATAL_STDERR_=1
+ PERLDB_OPTS='NonStop?=1 AutoTrace?=1 frame=2 LineInfo?=/dev/null noTTY'
+ /usr/bin/perl -d /usr/local/bin/padre foo
Scalars leaked: 1

comment:5 Changed 3 years ago by adamk

Can anyone reproduce this on svn trunk, I haven't seen these in a while and I'm hoping we're done here.

comment:6 Changed 3 years ago by zenogantner

I also do not see this any more.

comment:7 Changed 2 years ago by azawawi

  • Resolution set to fixed
  • Status changed from assigned to closed

I do not see it anymore. Please reopen if anyone sees it :)

Note: See TracTickets for help on using tickets.