Ticket #262 (closed defect: worksforme)

Opened 5 years ago

Last modified 5 years ago

Padre crashes on exit

Reported by: kixx Owned by:
Priority: major Milestone:
Component: editor Version: trunk
Keywords: crash syntax_check Cc:

Description

Padre SVN @3223 ( $VERSION=0.28 )
Strawberry Perl 5.10.4
Windows XP Professional

When a file is opened while the Syntax Check Panel is enabled and the editor is closed with the file still open, Padre will crash (even is the Panel is disabled after opening the file).

It won't crash on exit if the Syntax Check Panel is enabled after opening the file or if the file is closed before exiting the editor.

The console output is:

D:\work\padre\Padre>perl dev.pl
Can't spawn "C:\strawberry\perl\bin\perl.exe": No error at dev.pl line 52.

Change History

comment:1 Changed 5 years ago by Casan

Confirmed:

  • crashes when closing padre when syntax check panel is enabled

and I may add:
+ The crash also occur when syntax_check panel is opened on start

and closed before closing padre.

+ But if it is not opened by default upon starting padre, and

then opened and then closed, beffore closing Padre, then = no crash.

Still exist on:
Vista
Strawberry 5.10.0.5
Parrot 1.1 and Rakudo .16
Syntax::Highlight::Perl6 v0.53
Padre::Plugin::Perl6 v0.38
Padre @4332 v0.34

comment:2 Changed 5 years ago by karl.forner

  • Status changed from new to closed
  • Resolution set to worksforme

Could not reproduce the bug using Padre 0.43 (from svn) on windows XP.
I installed Padre 0.41 from the .msi (so got strawberry perl and wxwidgets), then installed the 0.43 from svn.

Note: See TracTickets for help on using tickets.