Opened 6 years ago

Closed 6 years ago

#275 closed defect (fixed)

Thread indicator remains yellow

Reported by: szabgab Owned by:
Priority: major Milestone:
Component: editor Version: 0.29
Keywords: Cc:

Description

After some time or some operation - and I don't know what -
the thread indicator remains yellow.
It is not clear if the indicator is at fault or if a thread keeps working in the background.

Change History (3)

comment:1 Changed 6 years ago by tsee

Clicking on the thread indicator now writes a short status message to the output panel.

comment:2 Changed 6 years ago by szabgab

This seems to be the case:

Thread 1 terminated abnormally: Storable binary image v58.59 more recent than I am (v2.7) at ../../lib/Storable.pm (autosplit into ../../lib/auto/Storable/thaw.al) line 415, at /home/gabor/perl5lib/lib/Padre/Task/Perl6.pm line 136 thread 1

The & mark remained yellow, clicking on it tells me about Padre::Task::Perl6 running

I have wrapped the exception in an eval block now - in the Perl6 code.

comment:3 Changed 6 years ago by tsee

  • Resolution set to fixed
  • Status changed from new to closed

Thanks, fixed in r3390 at the cost of significantly more bookkeeping about the currently running tasks. There *is* however, a delay of a couple of seconds (up to 15 -- or was it 30? -- by default) until the crashed threads are joined and thus the task considered "done". This is by design. Checking for joinable threads too often is a waste of resources.

Given that there's quite a lot of tasks generally being run, this isn't such a bad thing as it may help us keep track down the road.

However: The whole "thread crashing" thing is a problem for itself. That's something that should not happen just as Padre itself shouldn't be crashing.

Note: See TracTickets for help on using tickets.