Opened 5 years ago

Closed 5 years ago

#289 closed defect (fixed)

scrolling at preference tab does not work

Reported by: davidgang Owned by:
Priority: minor Milestone:
Component: editor Version: 0.34
Keywords: Cc: pzschmidt@…

Description

When trying to scroll at preference tab it is stuck at the beginning
I am working on windows xp service pack 3 with strawberry perl 5.10.0.4

Change History (4)

comment:1 Changed 5 years ago by davidgang

  • Version changed from 0.32 to 0.33

The problem persists in 0.33

comment:2 Changed 5 years ago by pschmidt

  • Cc pzschmidt@… added
  • Priority changed from major to minor
  • Version changed from 0.33 to 0.34

Problem is still present in 0.34.

Because the panels used in the preferences dialog are using Wx::FlexGridSizer I suggest simply not to use Wx::wxVSCROLL and Wx::wxHSCROLL during the panel creation (Wx::FlexGridSizer automatically uses an appropriate window size to display all of its controls).

--- Padre/lib/Padre/Wx/Dialog/Preferences.pm    (Revision 4299)
+++ Padre/lib/Padre/Wx/Dialog/Preferences.pm    (Arbeitskopie)
@@ -19,7 +19,7 @@
                -1,
                Wx::wxDefaultPosition,
                Wx::wxDefaultSize,
-               Wx::wxTAB_TRAVERSAL | Wx::wxVSCROLL | Wx::wxHSCROLL,
+               Wx::wxTAB_TRAVERSAL,
        );
        my $fgs = Wx::FlexGridSizer->new( 0, $cols, 0, 0 );
        $panel->SetSizer($fgs);
@@ -101,7 +101,7 @@
                -1,
                Wx::wxDefaultPosition,
                Wx::wxDefaultSize,
-               Wx::wxTAB_TRAVERSAL | Wx::wxVSCROLL | Wx::wxHSCROLL,
+               Wx::wxTAB_TRAVERSAL,
        );
        my $main_sizer = Wx::BoxSizer->new(Wx::wxVERTICAL);
 
@@ -376,7 +376,7 @@
                -1,
                Wx::wxDefaultPosition,
                Wx::wxDefaultSize,
-               Wx::wxTAB_TRAVERSAL | Wx::wxVSCROLL | Wx::wxHSCROLL,
+               Wx::wxTAB_TRAVERSAL,
        );
        my $main_sizer = Wx::BoxSizer->new(Wx::wxVERTICAL);

comment:3 Changed 5 years ago by jquelin

fix applied as r4335.
(ask gabor for a commit bit, so you could commit directly)

since the problem is on windows, please check if it fixed the problem and close the bug if that's the case.

comment:4 Changed 5 years ago by pschmidt

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in version 0.35. Tested on MS Vista.

Note: See TracTickets for help on using tickets.