Opened 6 years ago

Closed 6 years ago

#293 closed defect (not a bug)

Install problems OpenSuse 11.0

Reported by: explorer Owned by:
Priority: minor Milestone:
Component: editor Version: 0.32
Keywords: Cc:

Description

perl, v5.10.0 built for x86_64-linux-thread-multi

Wx Version: 0.84 wxWidgets 2.8.8

cpan Perl
=========

#   Failed test 'STDERR of Padre/DocBrowser.pm'
#   at t/00-compile.t line 34.
#          got: 'Bareword "Wx::wxSTC_LEX_ESCRIPT" not allowed while "strict subs" in use at /root/.cpan/build/Padre-0.32-Y2HYr3/blib/lib/Padre/Document.pm line 123.
# Bareword "Wx::wxSTC_LEX_ESCRIPT" not allowed while "strict subs" in use at /root/.cpan/build/Padre-0.32-Y2HYr3/blib/lib/Padre/Document.pm line 123.
# Bareword "Wx::wxSTC_LEX_BASH" not allowed while "strict subs" in use at /root/.cpan/build/Padre-0.32-Y2HYr3/blib/lib/Padre/Document.pm line 123.
# Compilation failed in require at /root/.cpan/build/Padre-0.32-Y2HYr3/blib/lib/Padre/DocBrowser/POD.pm line 10.
# BEGIN failed--compilation aborted at /root/.cpan/build/Padre-0.32-Y2HYr3/blib/lib/Padre/DocBrowser/POD.pm line 10.
# Compilation failed in require at /root/.cpan/build/Padre-0.32-Y2HYr3/blib/lib/Padre/DocBrowser.pm line 9.
# BEGIN failed--compilation aborted at /root/.cpan/build/Padre-0.32-Y2HYr3/blib/lib/Padre/DocBrowser.pm line 9.
# Compilation failed in require at -e line 1.
# '
#     expected: ''
FAILED--Further testing stopped: Test failed.  BAIL OUT!.
make: *** [test_dynamic] Error 9
(/usr/bin/make test exited with 512)

padre-0.32-x86_64-linux-gnu-thread-multi
========================================

explorer@portatil:~/Documents/Software> file padre-0.32-x86_64-linux-gnu-thread-multi
padre-0.32-x86_64-linux-gnu-thread-multi: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), for GNU/Linux 2.6.8, dynamically linked (uses shared libs), stripped
explorer@portatil:~/Documents/Software> chmod 755 padre-0.32-x86_64-linux-gnu-thread-multi
explorer@portatil:~/Documents/Software> ./padre-0.32-x86_64-linux-gnu-thread-multi
explorer@portatil:~/Documents/Software> run3(): undefined command at ORLite/Migrate.pm line 104
BEGIN failed--compilation aborted at Padre/DB.pm line 22.
Compilation failed in require at Padre.pm line 33.
BEGIN failed--compilation aborted at Padre.pm line 33.
Compilation failed in require at script/padre line 53.

explorer@portatil:~/Documents/Software>

Change History (1)

comment:1 Changed 6 years ago by szabgab

  • Resolution set to not a bug
  • Status changed from new to closed

These should be two separate reports.
The first one - with the cpan installation - there for some reason CPAN.pm does not complain hard enough about unmet dependencies. You will have to upgrade Wx to 0.89 and there might be another few dependencies you have to install. This - if a bug - then it belongs to the toolchain of Perl and CPAN.

For the other one with the binary package, please open a separate ticket. That one we will have to investigate.

Note: See TracTickets for help on using tickets.