Opened 6 years ago

Closed 5 years ago

#314 closed defect (fixed)

Padre broken on MS Vista when starting with no file to be opened

Reported by: dlp Owned by: azawawi
Priority: major Milestone:
Component: editor Version: 0.47
Keywords: Vista Cc: pzschmidt@…

Description

It has been a couple of releases now that I have been unable to start Padre on MS Windows Vista/32bits. See the attached file for a view of what is happening at startup. I can access the menu items but I was never able to see any file in the editor.

StrawberryPerl? on Windows Vista:
C:\Perl\usr\Blog>perl -v
This is perl, v5.10.0 built for MSWin32-x86-multi-thread

C:\Perl\usr\Blog>perl -MWx -le"print qq(Wx Version: $Wx::VERSION ) . Wx::wxVERSION_STRING();"
Wx Version: 0.89 wxWidgets 2.8.8

Attachments (1)

Padre-0.35.jpg (39.2 KB) - added by dlp 6 years ago.

Download all attachments as: .zip

Change History (12)

Changed 6 years ago by dlp

comment:1 Changed 6 years ago by pschmidt

  • Cc pzschmidt@… added

I have no problems using Padre under MS Vista.
I installed version 0.34 as described in http://padre.perlide.org/wiki/Download in section "MS Windows Strawberry Perl" together with #258. I'm using Strawberry Perl 5.10.0.5, Wx Version: 0.89 and wxWidgets 2.8.8.
I'm also able to use version 0.35 from the SVN repository without problems.

comment:2 Changed 6 years ago by dlp

I've figured it out.
When you open Padre with a file open in the editor, then all is well in the world: I could navigate through all menus and windows normally.

However, when you exit Padre with no file in the editor, then next time you open it, the screen will look all messed up as described at the beginning of this defect.

Open a file and leave Padre. Next time you open up the application, all will be back to normal.

comment:3 Changed 5 years ago by szabgab

  • Priority changed from critical to major
  • Summary changed from Padre broken on MS Vista to Padre broken on MS Vista when starting with no file to be opened

comment:4 Changed 5 years ago by dlp

  • Version changed from 0.35 to 0.45

Problem still exists on version 0.45

comment:5 Changed 5 years ago by szabgab

  • Owner set to szabgab
  • Status changed from new to assigned

comment:6 Changed 5 years ago by azawawi

Maybe this is is related to ticket:545 . Please upgrade to Padre 0.47 since it uses padre.exe instead padre.bat?

comment:7 Changed 5 years ago by azawawi

  • Owner changed from szabgab to azawawi

comment:8 Changed 5 years ago by dlp

  • Version changed from 0.45 to 0.47

I upgraded to Padre 0.47 and the problem is still there:

  • Close all files in Padre
  • Close Padre
  • Open Padre: the screen is frozen and when I click on the File menu, all options become greyed out. Note: when I click on any other menu (Edit, Search, ..., Help), the options are shown correctly.

comment:9 Changed 5 years ago by szabgab

I think I would just disable this feature on Windows, that is, if the user selected start without any file padre would still start with a new file.

comment:10 Changed 5 years ago by getty

cant reproduce the bug with r8266
i opened padre, closed the "new file", set the preferences to start without any opened file, i closed padre, i restarted it (sidenote: all with dev.pl out of svn checkout) and i had an empty workspace and was able to open other files and new files, nothing greyed out.

comment:11 Changed 5 years ago by azawawi

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in r8535

Thanks for your patience :)

Note: See TracTickets for help on using tickets.