Opened 5 years ago

Closed 5 years ago

#328 closed defect (not a bug)

docbrowser mixes html with plain text

Reported by: jquelin Owned by: submersible_toaster
Priority: major Milestone:
Component: POD based help Version: 0.35
Keywords: Cc:

Description

(i know, the bug is more in pod::*)

open doc for yaml. check AUTHOR section at the end, it should read

Ingy doet Net <ingy@cpan.org>

however it reads

Ingy ? Net

the parts between angle brackets is ignored, since i guess inferior / greater than signs are not html escaped, and thus interpreted.

Change History (5)

comment:1 Changed 5 years ago by submersible_toaster

pls report platform.

DocBrowser? from padre0.32 displays.

Ingy döt Net

in author section after search for YAML

this appears for me on ubuntu 9.04 , padre 0.32 as
"Ingy dot Net" with two dots above the "o" in "dot"

comment:2 Changed 5 years ago by submersible_toaster

  • Owner set to submersible_toaster
  • Status changed from new to accepted

comment:3 Changed 5 years ago by jquelin

padre 0.35 on

$ perl -V
Summary of my perl5 (revision 5 version 10 subversion 0) configuration:
  Platform:
    osname=linux, osvers=2.6.22.18-server-1mdv, archname=x86_64-linux-thread-multi
    uname='linux seggie.mandriva.com 2.6.22.18-server-1mdv #1 smp mon feb 11 14:59:42 est 2008 x86_64 intel(r) pentium(r) d cpu 3.00ghz gnulinux '
    config_args='-des -Dinc_version_list=5.8.8 5.8.7 5.8.6 5.8.5 5.8.4 5.8.3 5.8.2 5.8.1 5.8.0 5.6.1 5.6.0 -Darchname=x86_64-linux -Dcc=x86_64-mandriva-linux-gnu-gcc -Doptimize=-O2 -g -pipe -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -DDEBUGGING=-g -Dprefix=/usr -Dvendorprefix=/usr -Dsiteprefix=/usr -Dsitebin=/usr/local/bin -Dsiteman1dir=/usr/local/share/man/man1 -Dsiteman3dir=/usr/local/share/man/man3 -Dman3ext=3pm -Dcf_by=Mandriva -Dmyhostname=localhost -Dperladmin=root@localhost -Dcf_email=root@localhost -Dd_dosuid -Ud_csh -Duseshrplib -Duseithreads -Di_db -Di_ndbm -Di_gdbm'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=define, usemultiplicity=define
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='x86_64-mandriva-linux-gnu-gcc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm',
    optimize='-O2 -g -pipe -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4',
    cppflags='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -I/usr/local/include -I/usr/include/gdbm'
    ccversion='', gccversion='4.3.2', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='x86_64-mandriva-linux-gnu-gcc', ldflags =' -L/usr/local/lib64'
    libpth=/usr/local/lib64 /lib64 /usr/lib64
    libs=-lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lpthread -lc
    perllibs=-lnsl -ldl -lm -lcrypt -lutil -lpthread -lc
    libc=/lib/libc-2.9.so, so=so, useshrplib=true, libperl=libperl.so
    gnulibc_version='2.9'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E -Wl,-rpath,/usr/lib/perl5/5.10.0/x86_64-linux-thread-multi/CORE'
    cccdlflags='-fPIC', lddlflags='-shared -O2 -g -pipe -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -L/usr/local/lib64'


Characteristics of this binary (from libperl):
  Compile-time options: MULTIPLICITY PERL_DONT_CREATE_GVSV
                        PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP USE_64_BIT_ALL
                        USE_64_BIT_INT USE_ITHREADS USE_LARGE_FILES
                        USE_PERLIO USE_REENTRANT_API
  Locally applied patches:
        Mandriva Linux patches
  Built under linux
  Compiled at Apr 16 2009 13:51:37
  %ENV:
    PERL5LIB="/home/jquelin/lib/perl5"
  @INC:
    /home/jquelin/lib/perl5
    /usr/lib/perl5/site_perl/5.10.0/x86_64-linux-thread-multi
    /usr/lib/perl5/site_perl/5.10.0
    /usr/lib/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi
    /usr/lib/perl5/vendor_perl/5.10.0
    /usr/lib/perl5/5.10.0/x86_64-linux-thread-multi
    /usr/lib/perl5/5.10.0
    /usr/lib/perl5/site_perl
    /usr/lib/perl5/vendor_perl/5.8.8
    /usr/lib/perl5/vendor_perl
    .

using unicode capable wx

comment:4 Changed 5 years ago by submersible_toaster

Hang on. You've opened another ticket about unicode. I've cross posted my reply to that in here.

<ingy@…> is a literal as far as i can gather from perlpodspec.
POD::Simple::XHTML does not treat it as a pod formatting code , nor it seems thinks it should be escaped as html.

Pod::Html is kinder - deciding that that @ in there signals that you MEAN L<mailto:ingy@…> - without the @ <ingy_AT_cpan.org> is escaped as you might expect.

+10 dwimmery for Pod::Html
-1 podspec for YAML ;)

comment:5 Changed 5 years ago by submersible_toaster

  • Resolution set to not a bug
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.