Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#332 closed defect (fixed)

cutnpaste weirdness

Reported by: jquelin Owned by:
Priority: major Milestone:
Component: editor Version: 0.35
Keywords: Cc:

Description

reported by barbie

cut-n-paste doesn't appear to work if you select text to replace, just does

a delete, and wipes the contents of the copy-clipboard. On further
investigation, once you select any text, the copy-clipboard is deleted.

Change History (3)

comment:1 Changed 6 years ago by rjray

I have seen that <Ctrl-C> and <Ctrl-X> do not seem to be working. If there is content in the clipboard, <Ctrl-V> seems to work fine. If I switch to Padre with something in the clipboard to paste, pasting works OK. If I select text and choose Copy or Paste from the Edit menu, then the clipboard appears to be correctly populated and pasting works fine. It looks like just the <Ctrl-C> and <Ctrl-X> shortcuts that are not working.

comment:2 Changed 6 years ago by therek

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r4900 (adamk++).

comment:3 Changed 6 years ago by rjray

Confirmed on my just-updated install of 0.36.

Note: See TracTickets for help on using tickets.