Opened 5 years ago

Closed 2 years ago

#353 closed defect (not relevant)

Wide (UTF-8) characters cannot be input at start of a line

Reported by: rjray Owned by:
Priority: major Milestone:
Component: Multilingual Input Method Editor Version: 0.51
Keywords: Cc:

Description

While editing a file that has both straight ASCII (English) and UTF-8 (Russian) content, I found that if the cursor was at the start of a line, I could not enter any of the Russian characters. If I switched the keyboard back to the US layout and typed a character, or typed a non-wide character (such as a space), I could then continue typing wide characters.

After further experimentation, I have found the following behaviors:

  • Open a new document, you can immediately type wide characters
  • Immediately after hitting <Backspace> or <Delete>, you cannot
  • When you hit <Return> and are starting a new line, you cannot
    • Even if you were just typing them on the previous line
    • Even if Padre auto-indented the line for you by any amount

Change History (9)

comment:1 Changed 5 years ago by rjray

perl -v
This is perl, v5.10.0 built for i486-linux-gnu-thread-multi

perl -MWx -le'print "Wx Version: $Wx::VERSION " . Wx::wxVERSION_STRING()'
Wx Version: 0.9 wxWidgets 2.8.10

comment:2 Changed 5 years ago by szabgab

I was playing around with this a bit with Hungarian and Hebrew which is even worse as it is written right-to-left.
With Hungarian I sometimes see this behavior (e.g. after pressing Del I can type ú bout not ő )

I could not reproduce the same bug in the wxRichTextCtrl example of wxDemo. Could you please try that and let us know if you can reproduce it there ?

comment:3 Changed 5 years ago by szabgab

err, that was misleading as STC (Scintilla) - the one we use is called Wx::StyledTextCtrl? and the demo is using something else that is called wxRichTextCtrl so that's irrelevant.

comment:4 Changed 5 years ago by szabgab

Refining my findings:

After pressing Del I cannot type ő or ű but I can type any other Hungarian vowel.
If I press any key (including the Shift or Ctrl) after that the above two characters
can be also typed.

running on Ubuntu 9.04

$ perl -MWx -e'printf(qq(Wx Version=($Wx::VERSION) %s unicode=(%s)\n), Wx::wxVERSION_STRING(), Wx::wxUNICODE())'
Wx Version=(0.91) wxWidgets 2.8.9 unicode=(1)

comment:5 Changed 5 years ago by szabgab

See also http://www.nntp.perl.org/group/perl.wxperl.users/2009/07/msg6497.html
(a thread titled "STC and unicode issue in Padre")

comment:6 Changed 5 years ago by explorer

  • Version changed from 0.35 to 0.51

Linux OpenSuse? 11.2 64bits, $LANG es_ES.UTF-8, Padre v0.51, utf8 encoding, run Ok with utf8 chars.
Also if the utf char is the first one on a line.

$ perl -MWx -e'printf(qq(Wx Version=($Wx::VERSION) %s unicode=(%s)\n), Wx::wxVERSION_STRING(), Wx::wxUNICODE())'
Wx Version=(0.94) wxWidgets 2.8.10 unicode=(1)

comment:7 Changed 5 years ago by explorer

More problems with utf8:

  • Files directory dialog dont show utf 8 chars in file and dir names
  • Bookmark dialog dont show utf 8 chars into line translate word (línea)

Linux OpenSuSE v11.2
Perl v5.10.1
Padre v0.51
Wx v0.94
wxWidgets v2.8.10
$LANG es_ES.UTF-8

comment:8 Changed 3 years ago by szabgab

  • Component changed from editor to Multilingual Input Method Editor

comment:9 Changed 2 years ago by bowtie

  • Resolution set to not relevant
  • Status changed from new to closed

no test code hence closed

Note: See TracTickets for help on using tickets.