Ticket #419 (closed enhancement: fixed)

Opened 5 years ago

Last modified 4 years ago

find variable declaration does not work at the end of a variable

Reported by: daxim Owned by: patrickas
Priority: minor Milestone:
Component: editor Version: 0.50
Keywords: Cc:

Description

  1. Insert the document:
    {
        my $foo;
        frob $foo;
    }
    
  2. Position the cursor before the last semicolon.
  3. Select menu item Perl → Find Variable Declaration.

What should happen:
Cursor jumps to before »m«.

What actually happens:
Dialog message: »Current cursor does not seem to point at a variable«

Change History

comment:1 Changed 5 years ago by tsee

  • Type changed from defect to enhancement

Snarky reply: If you point the cursor at a semicolon, it *doesn't* point at a variable.

Reasonable reply: A bit of DWIM here would certainly be useful, but this is not a bug per se.

comment:2 Changed 4 years ago by patrickas

  • Owner set to patrickas
  • Status changed from new to accepted
  • Version changed from 0.38 to 0.50

The same patch that fixes Ticket #654 (attached to that bug) should also fix this issue.

comment:3 Changed 4 years ago by Sewi

Fixed in r9168

comment:4 Changed 4 years ago by patrickas

  • Status changed from accepted to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.