Ticket #421 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

crash: no documents, F3/F4

Reported by: daxim Owned by:
Priority: critical Milestone:
Component: editor Version: 0.50
Keywords: Cc:

Description

  1. Run padre, start with no documents.
  2. Press F3.

What should happen:
Nothing.

What actually happens:
Crashes with »Can't call method "GetLength" on an undefined value at …/lib/perl5/site_perl/5.10.0/Padre/Wx/Dialog/Find.pm line 460.«


Alternatively:

  1. Press F4.

What should happen:
Nothing.

What actually happens:
Crashes with »Can't call method "GetSize" on an undefined value at …/lib/perl5/site_perl/5.10.0/Padre/Wx/Dialog/Search.pm line 197.«

Change History

comment:1 Changed 5 years ago by szabgab

  • Status changed from new to closed
  • Resolution set to fixed

These crashes are fixed in r5744 but the real source of the problem is bigger and is described in #426

comment:2 Changed 4 years ago by daxim

  • Status changed from closed to reopened
  • Version changed from 0.38 to 0.50
  • Resolution fixed deleted

Pressing F3 with no documents crashes with

Can't call method "GetSelection?" on an undefined value at .../lib/perl5/site_perl/5.10.1/Padre/Action/Search.pm line 54.

F4 is okay.

comment:3 Changed 4 years ago by azawawi

  • Status changed from reopened to closed
  • Resolution set to fixed

Fixed in r9398

Note: See TracTickets for help on using tickets.