Ticket #422 (closed enhancement: duplicate)

Opened 5 years ago

Last modified 3 years ago

does not backup unsaved work

Reported by: daxim Owned by:
Priority: critical Milestone:
Component: editor Version: 0.38
Keywords: Cc:

Description

  1. Run padre and create a new document.
  2. Work some minutes on it.
  3. Crash the app, or the X server. (Can be simulated by running xkill and clicking the window, or pressing Ctrl+Alt+Backspace twice.)
  4. Restart padre.

What should happen:
Restores my work.

What actually happens:
Unsaved work is irretrievably gone.


http://daringfireball.net/2009/02/untitled_document_syndrome

So one conclusion to draw from this is that developers of document-based applications should protect users from themselves. Your work should be saved even if your document is not. Separate the management of items in the file system from the idea that what you’ve typed or drawn or edited should be “safe”. BBEdit 9 has a good implementation of such a feature. Once a minute, it silently and invisibly stores a copy of every open document window. If BBEdit crashes or otherwise exits abnormally (like, say, if the entire system goes down), when next you launch BBEdit, it restores your work to the last auto-saved state. The worst case scenario is that you lose 59 seconds of work.

tl;dr: Backup all the work everytime the app is idle, or when the window is minimised, but at least once every minute.

Change History

comment:1 Changed 4 years ago by waxhead

From an implimentation point of view, should these temporary "unsaved" files be saved in the OS's TEMP directory ( which may be cleaned out on restart ) or the users notion of the home directory across OS's?

I suspect TEMP should be across the board and be better than what we currently have?

comment:2 Changed 3 years ago by zenogantner

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #105

Note: See TracTickets for help on using tickets.