Ticket #441 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Padre freezes with gtk+ 2.17.x (linux / wxgtk)

Reported by: shlomif Owned by:
Priority: major Milestone:
Component: editor Version: trunk
Keywords: Cc:

Description

Hi all!

On:

https://opensvn.csie.org/linuxisrael/list-of-mailing-lists/trunk/iglu.org.il

When editing test.pl with padre, and editing the line:

{{{{{{{
$main_r->email_address("shlomif", "iglu.org.il");
}}}}}}}

I'm getting sluggish behaviour whenever I enter a new character. A workaround is to use the scrollwhell.

I've tried it with Padre trunk. I'm using Padre on Mandriva Linux Cooker.

Change History

comment:1 Changed 5 years ago by jquelin

i can reproduce it, and it seems to be related to outline view: when closing it, the problem disappears...

easiest way to reproduce: open padre with outline view, and open a non-perl file.

this is really a big problem, making outline view really unusable.

comment:2 Changed 5 years ago by jquelin

hmm, in fact it still happens without outline view... :-(
dunno from where it comes then.

comment:3 Changed 5 years ago by jquelin

r2000 and r4000 are also experiencing this, whereas they were not at the time we commit them.

==> problem comes from outside of padre

comment:4 Changed 5 years ago by jquelin

also tried to install perl-Wx 0.90, but problem still persists...

also tried with a hand-compiled perl with own modules fetched & installed by local cpan, but problem still persists...

currently on mandriva Wx 0.91, wxgtk 2.8.10

dunno what to try now...

comment:5 Changed 5 years ago by jquelin

wxgtk2.8 has not been touched on mandriva since 3 monthes
(cf http://svn.mandriva.com/cgi-bin/viewvc.cgi/packages/cooker/wxgtk2.8/current/)

so it does not seem to be the culprit...

comment:6 Changed 5 years ago by Sewi

not reproducable on Ubuntu 9.04, Padre trunk r6984, Perl 5.10.0, Wx 0.91

comment:7 Changed 5 years ago by jquelin

bug also reported in mandriva bugzilla - cf https://qa.mandriva.com/show_bug.cgi?id=52802

comment:8 Changed 5 years ago by jquelin

just for the records: i tried r6984 too, and can reproduce the problem (editing the dev.pl file shipped with padre)

mandriva cooker, padre trunk r6984, perl 5.10.0, wx 0.91

comment:9 Changed 5 years ago by shlomif

This bug is now tracked in the GNOME bugzilla for gtk+-2.17.x:

http://bugzilla.gnome.org/show_bug.cgi?id=591583

Regards,

-- Shlomi Fish

comment:10 Changed 5 years ago by jquelin

  • Summary changed from Padre freezes when editing certain line of a file (workaround: use the scroll wheel) to Padre freezes with gtk+ 2.17.x (linux / wxgtk)

comment:11 Changed 5 years ago by jquelin

  • Status changed from new to closed
  • Resolution set to fixed

fixed in gtk+2.0-2.17.11-2mdv

Note: See TracTickets for help on using tickets.