Ticket #444 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

padre does not install on windows with strawberry perl 5.10

Reported by: davidgang Owned by: garu
Priority: major Milestone:
Component: editor Version: 0.40
Keywords: Cc: alexchorny@…

Description

Hi,

Here is the error log.

'inc', 'blib\lib', 'blib\arch')" t/*.t
t/00-compile.t ......... skipped: Needs DISPLAY
t/01-load.t ............ 1/22 # Tests find Wx: 0.91 wxWidgets 2.8.10
t/01-load.t ............ ok
t/02-new.t ............. ok
t/03-wx.t .............. skipped: Windows currently has problems with Unicode fi
les
t/04-config.t .......... ok
t/05-project.t ......... ok
t/06-utils.t ........... ok
t/07-log.t ............. ok
t/08-style.t ........... ok
t/10-copyright.t ....... ok
t/11-badcode.t ......... ok
t/50-docbrowser.t ...... skipped: Cannot run as root
t/60-db.t .............. ok
t/70-document.t ........ ok
t/71-perl.t ............ ok
t/72-dialog-html.t ..... ok
t/75-perl-beginner.t ... ok
t/80-newline.t ......... ok
t/81-search.t .......... ok
t/82-plugin-manager.t .. ok
t/83-autosave.t ........ ok
t/84-task.t ............ ok
t/85-task-manager.t .... ok
t/86-service.t ......... You tried to run a test without a plan at t/86-service.
t line 66.
t/86-service.t ......... Dubious, test returned 255 (wstat 65280, 0xff00)
No subtests run
t/91-vi.t .............. ok

Test Summary Report


t/86-service.t (Wstat: 65280 Tests: 0 Failed: 0)

Non-zero exit status: 255
Parse errors: No plan found in TAP output

Files=25, Tests=1469, 123 wallclock secs ( 0.77 usr + 0.17 sys = 0.94 CPU)
Result: FAIL
Failed 1/25 test programs. 0/1469 subtests failed.
dmake.EXE: Error code 255, while making 'test_dynamic'

SZABGAB/Padre-0.39.tar.gz
C:\strawberry\c\bin\dmake.EXE test -- NOT OK

hint to see the cpan-testers results for installing this module, try:

reports SZABGAB/Padre-0.39.tar.gz

Running make install

make test had returned bad status, won't install without force

Failed during this command:

SZABGAB/Padre-0.39.tar.gz : make_test NO

Change History

comment:1 Changed 5 years ago by davidgang

  • Version changed from 0.39 to 0.40

also persists in 0.40

comment:2 Changed 5 years ago by davidgang

bug also in 0.41

comment:3 Changed 5 years ago by garu

  • Owner set to garu
  • Status changed from new to accepted

Hi David. First of all, many thanks for the report!

This is a known bug happening during instalation, when our Makefile.PL fails to require Test::More version 0.88 or higher. If you upgrade Test::More, the problem should go away. Can you please confirm this for us?

However, we still think of it as a major problem and hope to fix this on next releases. If you can share with us your installation procedure that triggered the issue (manual "perl Makefile.PL && make && make test", pip, "cpan .", "cpan Padre", "install Padre" from within the cpan shell, cpanplus, etc), we would really appreciate it.

Again, thanks for the report! And please let us know if you find anything else.

comment:4 Changed 5 years ago by chorny

  • Cc alexchorny@… added

David, Strawberry uses CPAN::SQLite for CPAN shell. If you have CPAN.pm version lower than 1.94, try upgrading to 1.94 (1.9402 has problems on Windows) - previous version has exactly this problem.

comment:5 Changed 5 years ago by davidgang

  • Status changed from accepted to closed
  • Resolution set to fixed

I upgraded to the latest version of test::more and it solved the problem. The upgrade of cpan was not necessary, it also worked with version 1.9304. Thanks to you all

Note: See TracTickets for help on using tickets.