Opened 5 years ago

Closed 5 years ago

#485 closed defect (fixed)

Ctrl-keys don't work properly

Reported by: kaare Owned by:
Priority: major Milestone:
Component: editor Version: 0.42
Keywords: Cc:

Description

This applies to both a completely new OpenSUSE 11.1 installation, and an existing one.

Lots of ctrl-key combinations simply don't work. Ctrl-Z, Ctrl-Y, Ctrl-V, Ctrl-X, etc.

Problem exists Scintilla. No problem when using PPI.

OpenSUSE 1.1, KDE 4.3,
Perl 5.10.0, Padre 0.42, Wx 0.91/0.92, wxWidgets 2.8.9/2.8.10.

This doesn't appear in 0.41. In fact, going back to 0.41 solves this problem. What happened with Scintilla between 0.41 and 0.42?

Refocusing Padre (eg switching to another desktop and back) toggles the behaviour.

Change History (4)

comment:1 Changed 5 years ago by kaare

Sorry, after re-checking I notice the same problem with PPI.

So the problem is independent on the syntax highlighter engine.

comment:2 Changed 5 years ago by kaare

The problem appears in svn r6502 - it works in r6501

comment:3 Changed 5 years ago by azawawi

Is this bug still valid on Padre 0.46 or trunk?

comment:4 Changed 5 years ago by kaare

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.