Opened 5 years ago

Closed 2 years ago

#487 closed defect (fixed)

call tips not working when syntax check is on

Reported by: karl.forner Owned by:
Priority: major Milestone:
Component: editor Version: 0.43
Keywords: Cc:

Description

When the syntax check panel is displayed, and call tips are on,
the call tips ar enot properly working. If you double click on a function, nothing is displayed, and then if you double-click on another function, a tooltip appears but just for less than a second.

Steps to reproduce it:

1 - run a fresh version of Padre with nothing opened
2 - File->Open Example->.. open 01_simple_frame.pl
3 - ensure syntax panel is off and call tips are on
4 - double-click on the word "package" on line #3
5 - call tip should be displayed
6 - now toggle on the syntax panel
7 - double-click on the word "package" on line #3
8 - call tip is not displayed

Details:
on windows XP with strawberry perl

perl -v

This is perl, v5.10.0 built for MSWin32-x86-multi-thread
Wx Version=(0.91) wxWidgets 2.8.10 unicode=(1)

Change History (2)

comment:1 Changed 5 years ago by karl.forner

I found the origin of the problem
in Padre::Wx::Editor ::on_mouse_motion
if the syntax check is off, the function returns immediatelty, otherwise
is issues calls to either CallTipShow? or CallTipCancel?.
The problem is that I don't really know why...

comment:2 Changed 2 years ago by bowtie

  • Resolution set to fixed
  • Status changed from new to closed

this is not the case in r18108

Note: See TracTickets for help on using tickets.