Opened 5 years ago

Closed 3 years ago

#501 closed defect (fixed)

Padre crashes when installing CPAN Module

Reported by: John Owned by:
Priority: major Milestone:
Component: CPAN Module Installer Version: trunk
Keywords: Cc:

Description

Wx Version=(0.92) wxWidgets 2.8.10 unicode=(1) / This is perl, v5.10.0 built for i486-linux-gnu-thread-multi

Ubuntu jaunty, padre installed from SVN CO

Padre crashes when trying to install a CPAN Module via Plugins->tools->install CPAN module->clickety->boom.

Change History (5)

comment:1 follow-up: Changed 5 years ago by claudio

I can confirm this bug on 0.47 running on Ubuntu 9.04.

comment:2 in reply to: ↑ 1 Changed 5 years ago by karl.forner

Replying to claudio:

I can confirm this bug on 0.47 running on Ubuntu 9.04.

Have you looked at the stderr output in the console ?
Trying to install a module, I got:
L: Getopt::Euclid
mkdir /home/karl/.cpan/sources/authors/id/K/KG: Permission denied at /usr/local/share/perl/5.10.0/CPAN/FTP.pm line 501

DESTROY ignored because DBI dbh handle (DBD::SQLite::db) is owned by thread 81f3008 not current thread 9541550

Perl exited with active threads:

2 running and unjoined
0 finished and unjoined
0 running and detached

The important point is the mkdir... permission denied.
My guess is that you don't have the permissions to install a module, so it crashed.
Easy test/fix: run padre on root, and try again. In my case it worked.

comment:3 Changed 4 years ago by zenogantner

  • Component changed from plugins to advanced perl tools

#1031 looks similar.

comment:4 Changed 4 years ago by szabgab

  • Component changed from advanced perl tools to CPAN Module Installer

comment:5 Changed 3 years ago by bowtie

  • Resolution set to fixed
  • Status changed from new to closed

fixed in feature CPAN

Note: See TracTickets for help on using tickets.