Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#504 closed defect (fixed)

Lexically Rename Variable

Reported by: weismat Owned by: azawawi
Priority: major Milestone:
Component: editor Version: 0.47
Keywords: Cc:

Description

I am trying to use "Lexically Rename Variable" and it does not work as expected.
Simple program:
"my $a=1;
$a++;
print $a;"
I hightlight $a in the first line and put it as new name "$test" and also "test" and I always get the return pop-up "no decleration found for the specified (lexical?) variable.
Please let me know if you need any further info.

Change History (4)

comment:1 Changed 5 years ago by weismat

Ok - the reason is that I was always using double-click - when using the dragging as selection, then it works.

comment:2 Changed 5 years ago by azawawi

  • Owner set to azawawi
  • Status changed from new to assigned

comment:3 Changed 5 years ago by azawawi

  • Resolution set to fixed
  • Status changed from assigned to closed

This seems to be duplicate of ticket:586 which is now fixed.
Please test if it works for you or not.

Thank you.

comment:4 Changed 5 years ago by patspam

  • Version changed from 0.44 to 0.47

Seems to only work for me if the cursor is positioned before or in the variable, but not if the variable is selected (which is how I naively assumed it was to be used).

Very cool feature though! :)

Note: See TracTickets for help on using tickets.